Справка Invent EMS

Это справка по блоку управления двигателем INVENT EMS.

Справка разделена на две части:

Настройка
Работа с программой для настройки блока, описание всех опций, инструкции по настройке.

Подключение
Спецификации блока, различия в версиях, назначение выводов, подключение датчиков, катушек, форсунок, и т.п.

Дополнительные материалы вы можете найти на странице
http://invent-labs.com/download/

Также смотрите видео на нашем канале Youtube


Общая информация
Установка и крепление блока

Блок Invent предназначен для установки в салоне автомобиля.

Запрещается устанавливать блок в подкапотном пространстве, это приведет к его преждевременному выходу из строя.

Лучшее место для установки блока - под торпедой.
Необходимо обеспечить отток горячего воздуха в месте установки блока. Работающий длительное время блок должен быть слегка теплым.

Внутри блока установлен датчик абсолютного давления (ДАД). Датчик может выйти из строя при попадании внутрь воды или конденсата. В связи с этим при установке необходимо ориентировать блок так, чтобы штуцер подвода давления был направлен под углом вниз.

Правила подключения

Все выводы силовой земли необходимо надежно соединить в одной точке.
Землю питания необходимо подсоединить к общей точке заземления
Нельзя эксплуатировать блок без подключения всех выводов земли. Это может привести к поломке.
Запрещается брать питание 12В с точки подключения силовых устройств, потребляющих большой ток и создающих сильные помехи (катушки зажигания, форсунки, бензонасос, и т.п.) Это может вызвать сбои в работе ЭБУ и/или ДПКВ.

Сечение проводов

Силовая земля, катушки зажигания, подогрев лямбда зонда - 1.5мм²
Форсунки, питание 12В - 0.7мм²
Реле, соленоиды, и т.п. - 0.5мм²

Предохранители

Рекомендуется установка раздельных предохранителей. Посчитайте нужный номинал предохранителей по количеству и мощности подключенных устройств.

Катушки (по 14А на катушку)
Форсунки (1А или 5А для низкоомных),
Соленоиды (от 0.2 до 2-3А)
Реле (от 0.3А), и т.п. маломощные цепи
ЭБУ (5А + 5А на каждую низкоомную форсунку)


Как узнать версию блока
Подключитесь к блоку, откройте вкладку Параметры - Прошивка


v1.1
Первый релиз блока.
Было выпущено всего несколько штук.

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите крышку с логотипом.

Правильное положение перемычек:

Назначение выводов

В прошивке 4.х вход EXT1 = AN1, EXT2 = K


v1.2
В этом блоке используется микросхема шагового двигателя, которая вызвала много проблем, так как легко выходила из строя. В следующих версиях от нее отказались.

Есть два варианта блоков, которые отличаются расположением силовых ключей зажигания:

1.2 - ключи расположены на одной из стенок блока
1.2а - ключи расположены в шахматном порядке на обеих стенках блока. Это значительно улучшает охлаждение.

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите крышку с логотипом.

Правильное положение перемычек:

Назначение выводов 1.2а

В прошивке 4.х вход EXT1 = AN1, EXT2 = K

Назначение выводов 1.2

В прошивке 4.х вход EXT1 = AN1, EXT2 = K


v1.3
Из-за проблем с микросхемой шагового двигателя поддержка ШД удалена из блока.

Есть два варианта блоков, которые отличаются расположением силовых ключей зажигания:

1.3 - ключи расположены на одной из стенок блока
1.3а - ключи расположены в шахматном порядке на обеих стенках блока. Это значительно улучшает охлаждение.

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите крышку с логотипом.

Правильное положение перемычек:

Назначение выводов 1.3а

Назначение выводов 1.3


v1.4

Конструкция адаптировна под новый, гораздо более удобный корпус со сьемной верхней крышкой.
В блоке нет драйвера шагового двигателя.
Использована специализированная микросхема обработки сигнала ДПКВ. В результате помехоустойчивость значительно улучшилась.

Назначение выводов


v1.5

Блок подвергся серьезной доработке по схемотехнике и печатной плате.
Возвращена поддержка шагового двигателя. Использован надежный драйвер Infineon.
Добавлен аналоговый вход ЕХТ3
Предусмотрено подключение внешнего ДАД.
Удален второй канал ДД.

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите верхнюю крышку.

J7: режим работы входа NO
DNO - режим подключения датчика ДНО или датчика холла
VR - режим обычного зубчатого шкива

J6: режим работы входа UI
DH - подключен датчик Холла
VR - подключен индуктивный датчик

Назначение выводов

* - Выход COIL5 используется также как INJ6 или H1
** - Выход COIL6 используется также как INJ5 или H2
Если COIL5 / COIL6 не заняты катушкой или форсункой, они работает как настраиваемые выходы H1 / H2 с управлением по плюсу.


v1.6

Интерфейс USB
Добавлен выход BUS для подключения экрана или логера
Добавлен ШИМ выход PWM3
Добавлен аналоговый вход AN2

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите верхнюю крышку.

J8: режим работы входа NO
всегда включайте режим VR

J6: режим работы входа UI
DH - подключен датчик Холла
VR - подключен индуктивный датчик

Назначение выводов

Входы AN1, AN2 - без подтягивающих резисторов.

* - Выход COIL5 используется также как INJ6 или H1
** - Выход COIL6 используется также как INJ5 или H2
Если COIL5 / COIL6 не заняты катушкой или форсункой, они работает как настраиваемые выходы H1 / H2 с управлением по плюсу.


v1.7

Проведена работа над ошибками блока 1.6

Перемычки внутри блока

Чтобы получить доступ к перемычкам снимите верхнюю крышку.

J7: режим работы входа NO
VR - подключен индуктивный датчик
DNO - подключен датчик ДНО или индуктивнёй датчик фазы

J6: режим работы входа UI
DH - подключен датчик Холла
VR - подключен индуктивный датчик

Назначение выводов

Входы AN1, AN2 - без подтягивающих резисторов.

* - Выход COIL5 используется также как INJ6 или H1
** - Выход COIL6 используется также как INJ5 или H2
Если COIL5 / COIL6 не заняты катушкой или форсункой, они работает как настраиваемые выходы H1 / H2 с управлением по плюсу.


v2.0

Блок построен на новом процессоре, что дало возможность расширить количество входов и выходов (12 выходов на катушки+форсунки). Также есть возможность установки дополнительного модуля управления электронным дросселем.

Назначение выводов


v2.1/2.2

Полностью переработана схемотехника, учтены все недоработки прошлой версии. Улучшена помехоустойчивость за счет полного разделения сигнальной и силовой части - они разнесены на противоположные стороны корпуса.
Есть возможность установки дополнительного модуля управления электронным дросселем.

Значительно расширено количество входов и выходов:

8 катушек
8 форсунок
6 ШИМ
7 доп. аналоговых входов
7 входов коленвала/распредвалов/скорости
12 универсальных силовых выходов

Это позволяет управлять мотором V8 c 4 регулируемыми распредвалами, 2 турбинами и электронным дросселем

Конфигурация перемычек

J5 - режим работы входа NO
VR - индуктивный датчик (например датчик скорости)
NO - датчик ДНО на маховике

J6 - режим работы входа UI
Если датчик коленвала — холл, джампер J6 на плате нужно установить в положение UIHALL. При этом входы UI и DH5 меняются местами. Датчик коленвала нужно подключать на вход DH5, а сигнал со входа UI программа видит как DH5.

Назначение выводов

COILx - катушки (14А) или внешние коммутаторы (управление +5В 20 мА)
INJx - форсунки (4А)
PWMx - мощные выходы ШИМ (4А)
A,B,C,D - шаговый двигатель или силовые выходы с двуполярным управлением (0.5А)
X1, X2, L1, L2 - выходы общего назначения (0.5А)
Н1, Н2 - силовые выходы с управлением по плюсу (0.5А)
Х3, Х4 - силовые выходы или ШИМ (0.5А)
TACH - тахометр
BUS - шина для дисплея или логгера

Все выходы имеют управление по минусу, если не указано иное

Все выходы GND необходимо подключить проводами 2.5мм² (1мм² если нет встроенных коммутаторов) и надежно соединить в одной точке.
Питание 12В необходимо подключить проводом 1мм².

5V — питание датчиков
SGND — земля датчиков. Минусовые провода от датчиков необходимо подключать к этому выводу, не соединяя их с общей землей. Экраны от датчиков подключайте на противоположную сторону блока, на силовую землю GND
UI - индуктивный датчик коленвала
NO - индуктивный датчик скорости или датчик ДНО
DH1..2 — датчики холла
AN1..5 — входы аналоговых датчиков без подтяжки.
AN6..7 — входы аналоговых датчиков с подтяжкой (2кОм +5В). Подходят для подключения датчиков температуры.

DH3..4 — по умолчанию датчики холла. Под заказ могут быть индуктивными.
При этом устанавливается дополнительный разьем с контактами DH3- и DH4-


v2.3

Пыле-влагозащищенный корпус и разьем. Улучшена схемотехника.

Входы и выходы:

8 катушек
8 форсунок
6 ШИМ
8 доп. аналоговых входов
7 входов коленвала/распредвалов/скорости
12 универсальных силовых выходов

Это позволяет управлять мотором V8 c 4 регулируемыми распредвалами, 2 турбинами и электронным дросселем

В блоке нет перемычек, конфигурация осуществляется с помощью

Назначение выводов

COILx — выход на коммутаторы (5В 20 мА)
INJx - форсунки (4А)
PWMx - мощные выходы ШИМ (4А)
A,B,C,D - шаговый двигатель или выходы общего назначения с двуполярным управлением (0.5А)
X1, X2, L1, L2 - выходы общего назначения (0.5А)
Н1, Н2 - выходы общего назначение с управлением по плюсу (0.5А)
Х3, Х4 - выходы общего назначения или ШИМ (0.5А)
TACH - тахометр
BUS, BUS_IN - шина для дисплея или логгера
М1, М2 - мотор электронного дросселя
S1, S2 - датчики положения заслонки электронного дросселя

Все выходы имеют управление по минусу, если не указано иное

Три выхода GND необходимо надежно соединить в одной точке. Оставшийся выход не подключайте к массе, подключите на него минусы датчиков (обозначены на схемах как SGND)

Если используется модуль электронного дросселя — подключать обе линии 12В, в противном случае достаточно одной линии.
12В и GND необходимо подключать проводом не меньше 1,5мм².

5V — питание датчиков
UI, DNO — индуктивные датчики
DH1..2 — датчики холла
DH3..4 — по умолчанию датчики холла. Под заказ могут быть индуктивными. В этом случае задействуются выводы DH3- и DH4-
AN1,2,3,4,8 — входы аналоговых датчиков без подтяжки.
AN5,6 — входы аналоговых датчиков с подтяжкой (2кОм +5В). Подходят для подключения датчиков температуры.
AN7 — вход с маломощной подтяжкой к 0,45в. Используется для подключения второго лямбда-зонда или как обычный вход AN без подтяжки.

VR+, DNO+, VR- вход ДНО или индуктивного датчика.
При подключении датчика ДНО либо индуктивного датчика фаз, используйте входы DNO+ и VR-.
При подключении датчика АБС или другого датчика с большой частотой импульсов - используйте входы VR+ VR-


Способы подключения ДПКВ
Здесь рассмотрены общие принципы различных вариантов подключения.
Электрические подробности смотрите в разделах Подключение ДПКВ и Подключение ДФ .
Расшифровку названия прошивки смотрите здесь
Настройки ДПКВ смотрите здесь

Датчик холла, трамблерная шторка (прошивка "a")

Предназначена для подключения к трамблеру или подобному сигналу. Сигнал подключается на вход ДУИ.

Стандартная ширина окна в шторке трамблера - 30 градусов (60 градусов по коленвалу). Отличия ширины окна компенсируются с помощью коррекции нулевого угла. Если ширина окна меньше 25 градусов - это будет ограничивать максимально возможный УОЗ.

Шторка 4 цил (привод от распредвала):
Шторки 4 цил (привод от коленвала):

Фазировка

Вариант 1 - обычный датчик фазы. Подходит для любой шторки.

Вариант 2 - расширенное окно первого цилиндра. Подходит только для шторки с приводом от распредвала.

Необходимо расширить задний край окна на 10%-15% (примерно 6-10 градусов). Программа определит расширенное окно при активации фазированного впрыска или зажигания.
Таким образом можно организовать фазированный впрыск/зажигание с помощью одного датчика холла.

Два датчика, ДУИ-ДНО (прошивка "b")

Вариант ДУИ-ДНО

Обычно это два датчика на маховике. Один из них, ДУИ (датчик угловых импульсов), считывает зубья венца стартера. Второй, ДНО (датчик начала отсчета), считывает специальный штифт на маховике.

Решение проблем с ДУИ-ДНО

Для фазировки нужен отдельный датчик фазы.

Эта система используется на 5-цилиндровых двигателях Audi, а также в Москвич 2141.

Штифт ДНО на маховике:

Вариант ДУИ-ДФ

ДУИ считывает угловые импульсы
ДФ считывает импульс первого цилиндра

Если ДУИ расположен на коленвале, а ДФ на распредвале (Ford Probe), то система может использоваться только при малом количестве зубов ДНО, не больше 12. Это обусловлено люфтом распредвала относительно коленвала.
Если оба датчика расположены на распредвале (Toyota Celica), то ограничения по количеству зубов нет.

Индуктивный датчик ДУИ-ДФ на распредвале Toyota Celica:

Варианты подключения ДФ

1. Индуктивный ДФ. Подключается на вход ДНО. В настройках ДФ указывается 0 зубов и инверсия.

2. ДФ холла. Подключается на входы ДФ и ДНО параллельно.

Шкив с пропуском зубьев (прошивка"c")

Прошивка для шкивов с отсутствующими зубьями. Зубов может быть любое количество при одном условии:

КоличествоЗубов * 2 / КоличествоЦилиндров = целое число

Шкив 60-2 подходит для любого количества цилиндров: 2,3,4,5,6,8,10,12
Шкив 36-1 подходит только для парного количества цилиндров

Способ установки самодельного шкива:
установить коленвал в положение ВМТ первого цилиндра
провернуть коленвал по ходу на 10-15 градусов
установить шкив так чтобы датчик смотрел на пропущеные зубья
проворачивать коленвал дальше по ходу вращения, до ближайшей ВМТ, и посчитать количество зубов, прошедших датчик.
записать полученное значение в параметр НО-МТ

Шкив 60-2 (большинство современных авто):

Шкив 36-1 (Ford, американские авто):

Шкив 36-2-1 (Mitsubishi)

Шкив с двойным зубом (прошивка "d")

Предназначена для шкивов с двойным зубом.

Шкив 12+1 (Honda K20):

Оптический датчик Nissan CAS (прошивка "m")

Для оптических датчиков Nissan, которые выдают 360 угловых импульсов на оборот распредвала. Это 180 импульсов на оборот коленвала. Поэтому в параметре "количество зубов ДПКВ" необходимо указать 180.

Второй датчик считывает окна различного размера. Для синхронизации необходимо указать в параметре "Количество импульсов ДФ" количество угловых импульсов, которые помещаются в окно наибольшего размера.

Nissan 240SX 4-цил


Датчик положения коленвала (ДПКВ)

Датчики положения коленвала

Датчик коленвала Холла

Датчик холла позволяет использовать неэкранированный провод. Такой датчик лучше работает при сильных помехах, когда индуктивный датчик использовать невозможно. При очень сильных помехах рекомендуется делать экранировку проводов к датчику.

Подключение к блоку v2.1 и новее
Откройте крышку и установите перемычки для работы с ДХ
В блоке v2.3 режим ДХ устанавливается программно

Подключение к более старым версиям
В блоке 1.2 необходимо подключить UI2/DPKV2 на землю
В других версиях откройте крышку и установите перемычки для работы с ДХ

Индуктивный датчик коленвала

Провод должен быть экранирован по всей длине. Каждый сантиметр неэкранированного провода становится антенной для помех от зажигания, стартера, генератора, и т.д.
Провод ДПКВ необходимо расположить как можно дальше от катушек и высоковольтных проводов.
Если датчик 3-проводной, третий контакт - это экран. Его следует соединить с экраном провода. Определить, какой из контактов подсоединять к экрану, можно тестером. Найдите пару контактов, между которыми сопротивление от 200Ом до 5кОм - это контакты 1 и 2. Следовательно третий контакт, который не прозванивается - экран.
Экран нужно подключить на силовую землю возле блока.

Датчик ДНО

ДУИ-ДНО - это система с двумя индуктивными датчиками. Датчик ДУИ подключается по схеме индуктивного датчика (см. выше).
Все правила подключения ДУИ (экранирование и т.п.) используются и для подключения ДНО.

Подключение к блоку 2.3

Подключение к блоку 1.4 / 1.6 / 2.0
резисторы - любые маломощные
если блок не видит импульс при прокрутке стартером - увеличивайте сопротивление нижнего резистора с 2кОм до 3кОм, затем до 4кОм

Подключение к остальным версиям
откройте крышку и установите режим ДНО перемычками

Следует уделить особое внимание полярности подключения ДНО. При неправильной полярности будут возникать ошибки синхронизации и сдвиги УОЗ.
Для определения полярности можно использовать схему приведенную ниже. Если полярность правильная - при резком приближении металлического предмета к датчику будет зажигаться светодиод. Если полярность неправильная - светодиод будет загораться при удалении предмета от датчика.

Особенности подключения к Audi S6 (AAN)

В штатной проводке сигналы ДУИ и ДНО соединены между собой и на землю. Нужно обязательно разрезать эти соединения, иначе система не сможет работать.


Датчик положения распредвала

Датчик распредвала
Датчик холла.

Вход DH(DH1) используется для фазировки. Также его можно задействовать и для измерения угла поворота распредвала.

Входы DH2, DH3 и т.д. могут использоваться только для измерения угла поворота распредвала. Фазировка по этих входах невозможна.

Индуктивный датчик


Решение проблем с ДУИ-ДНО
Типичная проблема ДУИ-ДНО - перескок импульса ДУИ через импульс ДНО при увеличении оборотов.
В логе оборотов это выглядит так:

Сравнение осциллограмм на ХХ и при возникновении ошибки. Здесь видна причина проблемы - при увеличении оборотов выше 6000 фронт импульса ДУИ перескакивает через фронт импульса ДНО.

Есть два варианта решения этой проблемы.

Первый - включение инверсии ДУИ. При этом система будет работат по другому фронту, и сигналы разносятся во времени.

Второй вариант - это физический сдвиг метки ДНО.Показан штриховой линией. При этом сигналы тоже разносятся во времени.


Датчик абсолютного давления (ДАД)
Встроенный ДАД
Внутри блока установлен датчик абсолютного давления (ДАД). Датчик может выйти из строя при попадании внутрь воды или конденсата. В связи с этим при установке необходимо ориентировать блок так, чтобы штуцер подвода давления был направлен под углом вниз.

ДАД нужно подключить с помощью вакуумной трубки к впускному коллектору. Желательно использовать пластиковую трубку, так как она меньше подвержена деформации, и реакция датчика будет точнее.Слишком тонкая трубка также будет замедлять реакцию датчика.

Нельзя подключать датчик в разветвление вакуумных шлангов других устройств, например вакуумного усилителя тормозов, разных соленоидов, и т.п. Это приводит к искажению показаний ДАД в момент их срабатывания.

Внешний ДАД
Следуйте правилам установки для внутреннего ДАД.

Установка штуцера в коллектор
Это можно сделать без снятия коллектора. Обильно обмазываете сверло солидолом, опилки будут прилипать. Как можно чаще снимаете опилки и обновляете смазку на сверле. Сверлите с минимальным усилием, особенно последние миллиметры. После сверления - пылесосом тщательны вытягиваете остатки из отверстия. Нарезаете резьбу (тоже со смазкой, как и сверление). Опять пылесосите отверстие и тщательно очищаете его от смазки. Капаете жидкость-фиксатор резьбы на штуцер и вкручиваете штуцер в коллектор. Штуцер можно купить в магазинах, торгующих ГБО.


Датчик температуры охлаждающей жидкости (ДТОЖ / CLT)
Блок рассчитан на установку резистивных датчиков с сопротивлением 1....5 кОм при 20 градусов.
Также можно использовать датчики 19.3828 / 406.3828 / 40.5226 (ГАЗ) с линейной зависимостью напряжения от температуры.
Минусовый провод датчика необходимо подсоединять только к выводу SGND. Подсоединение минуса на двигатель следует избегать, так как это приводит к повышению уровня помех и снижению точности измерений.


Датчик температуры впуска (ДТВ / IAT)
Блок рассчитан на установку резистивных датчиков с сопротивлением 1....5 кОм при 20 градусов.
Минусовый провод датчика необходимо подсоединять только к выводу SGND.

Датчик нужно устанавливать во впускном тракте. На турбомоторе - сразу после интеркулера. На атмосфернике - в трубу после воздушного фильтра.

Датчик, установленный во впускной коллектор, и расположеных вдали от потоков воздуха, не будет работать.

Необходимо обеспечить установку датчика в холодном месте, чтобы корпус датчика не нагревался от тепла мотора. Это существенно искажает показания. По этой же причине плохо работают датчики с металлическим корпусом.

Допускается использование ДТВ, установленного сразу после дроссельной заслонки в потоке воздуха (используется в турбомоторах VAG).


Датчик положения дроссельной заслонки (ДПДЗ / TPS)
Используется обычный 3-контактный ДПДЗ.

Как узнать расположение контактов на датчике

Берем тестер, и ищем пару контактов, между которыми сопротивление не изменяется при проворачивании оси датчика. Это будут контакты А и С. Их можно менять местами. Третий контакт соответственно будет контактом В.


Лямбда зонд (ЛЗ)
Блок поддерживает как узкополосный так и широкополосный лямбда зонд. Для широкополосного ЛЗ необходим внешний контроллер.

Питание контроллера широкополосного ЛЗ или подогрев узкополосного необходимо подсоединять проводом 1мм2 через реле. Управляющий провод реле питания ЛЗ нужно подключить на управляющий провод реле бензонасоса. Таким образом подогрев будет отключаться на остановленом двигателе.


Датчик детонации (ДД / Knock Sensor)
Датчик устанавливается на блоке (как можно выше) или на ГБЦ между центральными цилиндрами при помощи шпильки. При отсутствии штатной шпильки может быть использована любая другая шпилька на блоке. Датчик необходимо располагать в том же месте, где его устанавливают на заводе.
Возможно подключение двух ДД одновременно (входы DD1 и DD2). Такая система используется на V-образных двигателях или на оппозитах. Устанавливают по одному датчику на каждую половину двигателя.
Также возможно подключить два ДД на один вход. При этом сигналы с датчиков соединяются через резисторы 10кОм.
Важно подключить ДД правильной полярностью. Если полярность перепутана - сигнал будет слабее. Чтобы определить правильную полярность - попробуйте подключить датчик обеими полярностями, и оставьте тот вариант, при котором уровень сигнала выше.
Провод должен быть экранирован по всей длине!


Датчики скорости

Датчик скорости
Подключение датчика скорости к блоку v2.x

Индуктивный датчик

Датчик подключается на свободный индуктивный вход
В блоке 2.1 чтобы использовать вход DUI нужно переставить перемычку в режим индуктивного входа

Подключение параллельно к датчику ABS. Если провод экранирован - следует экранировать и подсоединение.

Датчик холла

Обычно это датчик скорости в КПП. Датчик подключается на свободный вход DHх.

Для параллельного подключения делается отвод от сигнального провода.


Катушки

Трамблерная раздача

Работает вывод COIL1. Для распределения искры используется штатный трамблер.

При использовании трамблера в качестве ДПКВ + разносчика искры необходимо убедиться, что бегунок покрывает весь рабочий диапазон УОЗ. Если трамблер с вакуумным и центробежным регуляторами - вам нужно зафиксировать грузики в положении макс. опережения, а также подогнуть тягу вакуумного регулятора в положение макс. опережения.

Попарно-параллельная искра

Одна катушка работает на два цилиндра одновременно. Другое название данного способа - метод холостой искры. Катушка подключается к противоположным парам цилиндров, в результате чего в одном цилиндре искра попадает на такт сжатия, и поджигает смесь, а в другом цилиндре искра попадает на такт выпуска, и работает вхолостую.
Используются раздельные двувыводные катушки, или же модули зажигания (сборки из нескольких двувыводных катушек в одном корпусе).
На 3 и 5 цилиндровых двигателях такое подключение невозможно.

Для 4 цилиндров схема наиболее простая:
Название выхода | Номер цилиндра
COIL1 | 1,4
COIL2 | 2,3

Определение пар цилиндров для других двигателей:

Берем порядок работы
1-4-2-5-3-6
записываем в две строки
1-4-2-
5-3-6
В столбцах будут пары цилиндров:
COIL1 -> цил 1,5
COIL2 -> цил 4,3
COIL3 -> цил 2,6

И еще один пример для 8 цилиндров:

Порядок работы:
1-5-4-2-6-3-7-8
записываем в две строки
1-5-4-2-
6-3-7-8
Получаем пары цилиндров:
COIL1 -> цил 1,6
COIL2 -> цил 5,3
COIL3 -> цил 4,7
COIL4 -> цил 2,8

Фазированная искра

На каждый цилиндр подключается индивидуальная катушка зажигания.

Катушки подключаются согласно порядку работы цилиндров. COIL1 всегда на первый цилиндр, далее по порядку работы. Например:

4 цилиндра
Название выхода | Номер цилиндра
COIL1 | 1
COIL2 | 3
COIL3 | 4
COIL4 | 2

5 цилиндров
Название выхода | Номер цилиндра
COIL1 | 1
COIL2 | 2
COIL3 | 4
COIL4 | 5
COIL5 | 3

Роторный двигатель

Название выхода |
COIL1 | Секция 1 нижняя свеча (Leading)
COIL3 | Секция 1 верхняя свеча (Trailing)
COIL2 | Секция 2 нижняя свеча (Leading)
COIL4 | Секция 2 верхняя свеча (Trailing)


Форсунки
Форсунки подключаются согласно порядку работы цилиндров. INJ1 подключается на первый цилиндр.

Пример подключения:

4 цилиндра
INJ1 -> 1 цилиндр
INJ2 -> 3 цилиндр
INJ3 -> 4 цилиндр
INJ4 -> 2 цилиндр

5 цилиндров
INJ1 -> 1 цилиндр
INJ2 -> 2 цилиндр
INJ3 -> 4 цилиндр
INJ4 -> 5 цилиндр
INJ5 -> 3 цилиндр

Важно! INJx и COILx должны подключаться к тому же цилиндру.


Подключение второго ряда форсунок

Подключение второго ряда форсунок форсунок
Подключение газовых форсунок (только EMS-2)

Через сплиттеры

Необходимо выбирать реле с запасом по току (пиковый ток газовой форсунки 4-5А)
Конструкция сплиттера: два диода с допустимым током не меньше 5А

Одновременно (только для EMS-2 4цил)

Драйвер форсунок устанавливается на каналы INJ5-INJ8. Каналы INJ1-INJ4 остаются обычными. Вы должны указать соотв. опцию при заказе блока.
Включите соотв. режим в настройках форсунок

Настройка ЭБУ

Настройка выходов

Реле газового клапана - режим "Газовый клапан"
Реле переключения питания рамп - режим "Газовая рампа"

Настройка входов

Датчики давления следует подключать на аналоговые входы без подтяжки. Датчики температуры - на входы с подтяжкой. См. назначение выводов вашего блока.

Внешний ДАД(если используется) - режим "Внешний ДАД"
Датчик давления газа - режим "Давление газа"
Датчик температуры газа - режим "Температура газа"

Другие настройки и проверка подключений

Датчик давления газа
Откалибруйте датчик
Снимите газовый шланг с датчика
Проверьте что отображатеся давление 100кПа (+- 5кПа)
Проверьте что датчик реагирует на разрежение/давление

Датчик температуры газа
Откалибруйте датчик
Проверьте что отображатеся температура окружающего воздуха
Подуйте в датчик, проверьте что датчик реагируетна теплый воздух

Если используется внешний ДАД:
Откалибруйте датчик
Перегрузите блок
Проверьте что отображатеся давление 100кПа (+- 5кПа)
Проверьте что датчик реагирует на разрежение/давление

Настройки Впрыск-Форсунка
Набор калибровок 1: драйвер форсунок ВЫКЛ, впрыск газа ВЫКЛ
Набор калибровок 2: драйвер форсунок ВКЛ, впрыск газа ВКЛ

Настройки драйвера газовых форсунок
Задайте длительность импульса открытия форсунки, сопротивление форсунки и ток удержания. Эту информацию можно посмотреть в документации на форсунку.

Подключение второго ряда бензиновых форсунок

Через сплиттеры

Конструкция сплиттера: два диода с допустимым током не меньше 5А

Одновременно (только для EMS-2 4цил)

Вы должны заказать блок на 8 цилиндров для этого варианта.
Включите соотв. режим в настройках форсунок

Настройка ЭБУ

Настройка выходов

Реле питания ряда 1 - режим "Форсунки ряд 1"
Реле питания ряда 2 - режим "Форсунки ряд 2"

Необходимо задать обороты, при которых отключается ряд 1 и включается ряд 2.
Для плавного переключения делайте зону совместной работы обеих рядов не меньше 1000об/мин., и зазор между включением и отключением не меньше 200об

Например:
Ряд 1: откл 4900 вкл 4700
Ряд 2: вкл 3900 откл 3700


Подключение газовых форсунок (EMS2)
Способы подключения газовых форсунок

Через сплиттеры

Конструкция сплиттера: два диода с допустимым током не меньше 5А

Одновременно (только для 4цил)

Драйвер форсунок устанавливается на каналы INJ5-INJ8. Каналы INJ1-INJ4 остаются обычными. Вы должны указать соотв. опцию при заказе блока.

Настройка ЭБУ

Настройка выходов

Реле газового клапана - режим "Газовый клапан"
Реле переключения питания рамп - режим "Газовая рампа"

Настройка входов

Датчики давления следует подключать на аналоговые входы без подтяжки. Датчики температуры - на входы с подтяжкой. См. назначение выводов вашего блока.

Внешний ДАД(если используется) - режим "Внешний ДАД"
Датчик давления газа - режим "Давление газа"
Датчик температуры газа - режим "Температура газа"

Другие настройки и проверка подключений

Датчик давления газа
Откалибруйте датчик
Снимите газовый шланг с датчика
Проверьте что отображатеся давление 100кПа (+- 5кПа)
Проверьте что датчик реагирует на разрежение/давление

Датчик температуры газа
Откалибруйте датчик
Проверьте что отображатеся температура окружающего воздуха
Подуйте в датчик, проверьте что датчик реагируетна теплый воздух

Если используется внешний ДАД:
Откалибруйте датчик
Перегрузите блок
Проверьте что отображатеся давление 100кПа (+- 5кПа)
Проверьте что датчик реагирует на разрежение/давление

Настройки Впрыск-Форсунка
Набор калибровок 1: драйвер форсунок ВЫКЛ, впрыск газа ВЫКЛ
Набор калибровок 2: драйвер форсунок ВКЛ, впрыск газа ВКЛ

Настройки драйвера газовых форсунок
Задайте длительность импульса открытия форсунки, сопротивление форсунки и ток удержания. Эту информацию можно посмотреть в документации на форсунку.


Микро-дисплей
Подключение

12V - питание, должно отключаться вместе с зажиганием
GND - земля
DIMMER - при подаче напряжения на этот вывод уменьшается яркость подсветки
BUS - линия данных с ЭБУ

При отсутствии соединения с ЭБУ на дисплее горит надпись "Invent Labs"

Можно подключить 2 дисплея одновременно.Для выбора адреса дисплея нужно включить питание и замкнуть контакты в верхнем левом углу платы (см. фото ниже). При каждом замыкании на дисплее будет меняться надпись Display 1-2-3-4. Выберите для первого дисплея адрес 1 а для второго адрес 2.

Подключение к ЭБУ без выхода BUS
Подключаемся к ком-порту.
12в и землю берем непосредственно от ЭБУ, а провод BUS тянем к дисплею.

Кнопка переключения экранов

Дисплей позволяет переключать экраны по кнопке. Кнопка без фиксации, подключается к ЭБУ.

EMS-2 имеет отдельный вход для кнопки дисплея
EMS-1 имеет один вход К, на который назначается нужная функция

Нужно подключить кнопку и активировать функцию "дисплей" в настройках входов


Электронный дроссель

Подключение привода дросселя

Дроссель содержит два датчика положения и мотор.

По линиях M1, M2 протекают токи до 8А.
Следует выбирать провода сечением от 1.5 мм.кв.

На вход S1 нужно подключать датчик, на котором минимальное напряжение при закрытом дросселе.

Подключение педали

Педаль содержит два независимых датчика положения. Один из них подключается на вход TPS, второй - на свободный вход AN без подтяжки (см. назначение выводов вашего блока).
Сигнал TPS должен показывать низкое напряжение при отпущенной педали

Распиновка разьема драйвера дросселя блока v2.2/2.3

По линиях +12V, PGND, M1, M2 протекают токи до 8А.
Следует выбирать провода сечением от 1.5 мм.кв.
12V и PGND следует подключать в той же точке, что и блок Invent ECU.

Распиновка дроссселя BMW 408.238/425/001

1 - s1
2 - sgnd
3 - М
4 - s2
5 - М
6 - +5

Распиновка дросселя ВАЗ


Тахометр и встроенный стробоскоп
Определение типа тахометра

Если у вас штатный тахометр подключался на катушку - тахометр высоковольтный. Ему нужны импульсы 50-100 вольт для срабатывания.
Если тахометр подключался к специальному выходу коммутатора, или к мозгу - тахометр низковольтный. Ему нужны импульсы 12 вольт для срабатывания.
Если вы не можете определить тип тахометра - сначала попробуйте низковольтную схему.

Высоковольтный тахометр

Нужно взять катушку от обычного автомобильного реле, и подключить таким образом. Вы получите генератор импульсов 50-70 вольт. Их достаточно для срабатывания тахометра.

Второй вариант подключения - без использования вывода ТАСН. С помощью диодов собираете сигналы с первичных обмоток катушек.

Если предыдущие варианты не работают, используйте обычный автомобильный коммутатор для усиления импульса.

Низковольтный тахометр

В новых блоках, начиная с версии 1.3, нужно просто подключить выход тахометра напрямую к тахометру.
Если у вас более старая версия, или же такое подключение не работает - воспользуйтесь следующей схемой.

Встроенный стробоскоп

Блок имеет функцию встроенного стробоскопа на выходе TACH. Для использования этого режима необходимо собрать простую схему на светодиодах. Используйте ультраяркие красные или синие светодиоды. Белые испольовать нельзя, они имеют слишком большую инерцию.
Внимание!
Не подключайте светодиоды до того как активируете режим стробоскопа!
Светодиоды сгорят!


Регулятор холостого хода (РХХ)

Шаговый РХХ

Поддерживается 4-выводной регулятор

Индуктивный РХХ (2-выводный)

Внутри - катушка и возвратная пружина. При подаче ШИМ-импульсов шток двигается пропорционально подаваемой мощности. При отключении питания шток возвращается в первоначальное положение.

Обычная частота ШИМ для РХХ - 70 Гц. Иногда встречаются клапана, для которых нужна другая частота. Частота подбирается экспериментально по максимальной линейности регулирования оборотов.

Индуктивный РХХ (3-выводный)

Внутри - две катушки. При подаче ШИМ-импульсов шток двигается пропорционально подаваемой мощности на катушки. При отключении питания шток возвращается в первоначальное положение.

Обычная частота ШИМ для РХХ - 70 Гц. Иногда встречаются клапана, для которых нужна другая частота. Частота подбирается экспериментально по максимальной линейности регулирования оборотов.

Подключение на 2 канала ШИМ

Необходимо подключать РХХ на спаренные выходы ШИМ, для которой устанавливается одна частота.

Подключение на один канал ШИМ

Необходима внешняя схема. Вы можете заказать ее при заказе блока Invent. Используется любой полевой транзистор на ток >5А, напряжение >55В. Пунктирной линией обозначен РХХ.


Лампа индикации ошибок Check Engine
Индикация ошибок светодиодом на блоке (лампа Check Engine)

Еле заметное бледное моргание. Блок не выходит на связь. | Прошивка не функционирует. Вам необходимо произвести процедуру заливки прошивки.
Частое моргание. Блок не выходит на связь | Найдена ошибка при проверке целостности прошивки. Вам необходимо произвести процедуру заливки прошивки.
Постоянно горит, двигатель остановлен | Блок функционирует нормально, проверка лампы
Постоянно горит, двигатель работает | Важная ошибка
Постоянно медленно моргает | Второстепенная ошибка
Одиночное редкое моргание | Сработала защита двигателя
Двойное редкое моргание | Закончился газ


Расшифровка названия прошивки
Пример названия прошивки: invent_ecu_v2_3.6.5с.ibf

'v2' обозначает версию блока, для которого предназначена прошивка: EMS-1 или EMS-2

'3.6.5' — это версия прошивки.
Для этой прошивки вам нужно использовать коммандер с такими же первыми двумя цифрами версии.
Например для прошивок 3.4.хх подходит коммандер 3.4.хх. А для прошивки 3.6.хх нужно использовать коммандер 3.6.хх.
Если вы ошиблись версией, коммандер предупредит вас.

'с' обозначают тип датчика коленвала , для которого предназначена прошивка.


Подключение и прошивка
Подключение

Для подключения выберите номер СОМ-порта, к которому подключен кабель, и нажмите кнопку ON.
Для отключения нажмите кнопку OFF.

Статусы подключения:
отключен - порт закрыт
поиск - порт открыт, идет поиск блока
подключен - соединение успешно

Обновление прошивки (вариант 1)

Включите зажигание
Подключитесь к блоку
Статус может быть или “Подключен” или “Поиск”

Откройте вкладку Настройки - Прошивка.
Выберите нужный тип прошивки.
Запустите обновление.

Дождитесь окончания загрузки

Подключитесь к блоку
Загрузите калибровки в блок

Обновление прошивки (вариант 2)

Используйте этот способ, если предыдущий не сработал. Этот вариант работает всегда (при условии что процессор не поврежден и связь с блоком работает).

Отключите зажигание
Задайте номер порта, но не подключайтесь. Статус должен быть “Отключен”

Откройте вкладку Настройки - Прошивка.
Выберите нужный тип прошивки.
Запустите обновление.

Дождитесь надписи “Поиск” и сразу же включите зажигание

Дождитесь окончания загрузки

Подключитесь к блоку
Загрузите калибровки в блок


Редактор таблиц
Выделение

Можно выделить одну или несколько ячеек с помощью мыши.
Клик на заголовок столбца выделяет весь столбец.
Клик на заголовок строки выделяет всю строку.
Клик на верхнюю левую ячейку заголовка выделяет всю таблицу.

Удерживайте Ctrl для выделения мышью нескольких ячеек или диапазонов.

Стрелки перемещают выделение
Shift + стрелки расширяют выделение в указаном направлении.

Изменение значений

Выделите нужные ячейки.

Различные способы изменения значений:
- Наберите число на клавиатуре и нажмите Enter
- PgUp/PgDn для пошагового изменения
- Ctrl + Вверх/Вниз для пошагового изменения
- Колесо мыши для пошагового изменения
- Длинный клик правой кнопкой -> Умножить - затем введите число и нажмите Enter

Интерполяция

Выделите нужные ячейки.

- клик правой кнопкой выполняет квадратную интерполяцию по 4-х крайних выделеных точках.
- длинный клик правой кнопкой -> интерполировать горизонтально - выполняет интерполяцию только по строках
- длинный клик правой кнопкой -> интерполировать вертикально - выполняет интерполяцию только по столбцах

Сетка оборотов

В таблицах УОЗ и наполнения есть возможность редактировать сетку оборотов.
Кликните правой кнопкой по заголовку таблицы и проставьте значения оборотов, которые нужно отображать.

3D просмотр

Нажмите кнопку [image] чтобы открыть окно 3D-просмотра.
Затем кликните на нужную таблицу, чтобы отобразить ее в 3D-окне.
Вращайте и масштабируйте изображение с помощью мыши.

Копирование таблиц

Длинный клик правой кнопкой -> Копировать данные таблицы - копирует данные в буфер обмена.

Длинный клик правой кнопкой -> Вставить данные таблицы - вставляет данные из буфера обмена.

Также вы можете копировать/вставлять данные из другой программы, например Excel.

Для таблиц с редактируемой сеткой оборотов доступны команды копирования/вставки сетки оборотов:
Длинный клик правой кнопкой -> Копировать/Вставить сетку оборотов


Калибровки
Работа с калибровками

При настройке мотора обычно используется автосохранение. Во время записи таблиц в память блока происходит кратковременная потеря синхронизации, поэтому автосохранение работает только если давление в коллекторе ниже 70 кПа. Таким образом реализована защита двигателя от повреждений при работе с полной нагрузкой. Вам необходимо сбросить газ для того чтобы данные сохранились в память блока
Запись калибровок в блок в процессе
Измененные калибровки ждут записи в блок. Для записи необходимо чтобы давление в коллекторе было ниже 70 кПа - для защиты двигателя. (в момент записи возникает кратковременный сбой синхронизации)
Калибровки сохранены в блок, но еще не записаны в энергонезависимую память. Нельзя отключать зажигание, иначе изменения будут потеряны.

После окончания работы рекомендуется записать все калибровки в блок, чтобы убедиться в том что все данные сохранены корректно

История изменений

Программа автоматически сохраняет текущую копию калибровок при чтении данных из блока или записи данных в блок, а также при каждом срабатывании автосохранения.

История сохраняется в папку /название_блока/history/


Логи
Запись и воспроизведение

Для начала записи нажмите кнопку [image] или F9
Имя файла создается автоматически. Счетчик времени будет показывать продолжительность записи.
Для остановки записи нажмите эту кнопку еще раз.

Для просмотра лога программа автоматически отключается от блока. Во время просмотра на всех приборах и индикаторах отображаются данные с текущей точки лога.

Графический просмотр

Управление мышью
Колесо - увеличение
Левая кнопка - установить маркер
Правая кнопка - перетаскивание графика влево/вправо

Управление с клавиатуры
Вверх/Вниз, PgUp/PgDn - увеличение
Влево/Вправо - прокрутка влево/вправо

Анализатор лога

Анализатор предназначен для наложения точек лога на карты зажигания и впрыска.
Откат по детонации
Отображает все точки в которых работал откат по детонации.

Уровень ДД выше
Позволяет отобразить только те точки, в которых сигнал с датчика был выше указанного уровня.

Отклонение смеси
Отбражает точки лога, в которых смесь отклонилась от целевой больше, чем указанное значение.

Мигание точек
Для лучшей видимости наложенные точки мигают.

Показать весь лог
Выводит серым цветом все точки лога


Приборы
Пиковое значение
Красная стрелка на приборах показывает максимальное пиковое значение. Чтобы сбросить пиковое значение - кликните правой кнопкой мыши по прибору.

Целевая смесь
Зеленая стрелка на приборе смеси показывает целевую смесь.
На примере: реальная смесь 11.8 а целевая 14.7

Дифференциальное давление газа
Показывается синей стрелкой на приборе давления

Лямбда-коррекция
Большая цифра отображает кратковременную (быструю) коррекцию
Маленькая цифра отображает долговременную (медленную) коррекцию
На примере: кратковременная коррекция +2, долговременная -5


Горячие клавиши

F1..F5 + 0..9 - Переключение вкладок.
Если нажать только F1..F5 - переключаются вкладки первого уровня.
Если удерживая F1..F5 нажать цифру - переключаются вкладки второго уровня.

F9 - Старт/стоп записи лога

Ctrl + F1 - вызов справки для текущей вкладки

Ctrl + Tab - открыть окно графиков

F11, F12 - быстрое изменение УОЗ на указаную величину


Автокалибровка
Автокалибровка предназначена для онлайн-построения карты наполнения по карте целевой смеси .

Автокалибровка работает во время поездки, собирая статистику и корректируя на лету карту наполнения.

Для работы автокалибровки нужно включить автосохранение и отключить лямбда-контроль.

Внимание! Автокалибровка не защитит от разрушения двигателя из-за бедной смеси и детонации. Перед началом автокалибровки установите в карте заведомо большие значения, чтобы обогатить смесь для защиты мотора. На критических режимах настройку желательно производить вручную.


История изменений
Программа автоматически сохраняет текущую копию калибровок при чтении данных из блока или записи данных в блок, а также при каждом срабатывании автосохранения.

История сохраняется в папку /название_блока/history/


Карта зажигания

Карты зажигания
Карта зажигания задает базовое значение УОЗ.
На это значение накладываются все остальные коррекции.


Другие
Угол зажигания на пуске
Таблица используется при запуске двигателя, и определяет УОЗ в зависимости от оборотов двигателя.
Работает от 400 об/мин и до достижения оборотов холостого хода.

Угол зажигания на ХХ
Таблица работает в режиме холостого хода, и определяет УОЗ в зависимости от оборотов двигателя.
В большинстве моторов угол на ХХ составляет 10-15 гр. На оборотах ниже ХХ угол следует приподнимать, это обеспечивает дополнительный крутящий момент при падении оборотов ниже нормы. На оборотах 2-2.5 тыс угол нужно поднимать до 20-30 гр, чтоб избежать хлопков в выхлопной трубе при сбросе газа.

Многоискровой пуск
На оборотах меньше 300 формируется пачка из 3 искр. Это позволят более уверенно поджигать смесь в сложных условиях.
Внимание! Если какие-либо системы автомобиля подключены к сигналу от катушки, то они могут работать некорректно.

Время накопления

На высоких оборотах время накопления автоматически уменьшается чтобы предотвратить перегрев катушек.
Актуальное время накопления можно увидеть в окне

Время накопления по напряжению
Таблица определяет время накопления энергии в катушках зажигания в зависимости от бортового напряжения.
Необходимое время накопления зависит от используемых катушек. Если у вас есть параметры катушек - вы можете воспользоваться калькулятором.

Время накопления по оборотам
Таблица позволяет при необходимости регулировать время накопления на различных оборотах.


Коррекции
Коррекция угла зажигания по Т двигателя
На холодном двигателе угол зажигания может быть на несколько градусов выше, чем на прогретом. Как правило выше 60 градусов коррекция должна быть 0. Ниже 60 градусов коррекция плавно увеличивается, и при температуре около ноля может достигать +5..10 градусов

Коррекция угла зажигания по Т впуска
При увеличении температуры впускного воздуха возрастает склонность к детонации. Таблица предназначена для компенсации этого явления

Коррекция угла зажигания по цилиндрах
Добавляет постоянную коррекцию к углу зажигания конкретного цилиндра.
Под цифрами 1-12 подразумеваются выходы Spark1-Spark12

Коррекция угла зажигания по ускорению коленвала
Корректирует УОЗ при резком увеличении оборотов коленвала. Это позволяет существенно улучшить динамику автомобиля на низших передачах.

При быстром увеличении оборотов коррекция в плюс делает угол раньше, коррекция в минус делает угол позже.

Принципы настройки:
-Сначала настраиваете основную карту УОЗ на высоких передачах. Затем с помощью коррекции улучшаете динамику и убираете детонацию на низких передачах.
- Не увеличивайте значение в карте бездумно. Вы получите слишком раннее зажигание, и возможно даже повреждение двигателя. Безопасные значения от 0 до 5. Выше - надо тщательно настраивать.
- На низких оборотах держите значения около 0. Отрицательные значения помогают бороться с детонацией при резком нажатии педали в пол.
- На средних и больших оборотах делайте коррекцию в плюс. Тщательно следите за двигателем, здесь очень легко сделать слишком раннее зажигание со всеми последствиями.

Сглаживание рывков
Делает отрицательную коррекцию по ускорению для плавного движения на малых оборотах. Отрегулируйте обороты и уровень для достижения плавности на малом нажатии педали.

На рисунке показано как применяются коррекции по ускорению и сглаживание.


Датчик детонации
Настройка датчика

Частота 1, обороты, частота 2
Эти параметры задают частоту фильтрации звука детонации.
Можно задать разные частоты для низких и высоких оборотов двигателя.

Это позволяет улучшить определение детонации в сложных случаях, когда на разных оборотах детонация происходит на разных частотах.
В большинстве случаев достаточно одной частоты детонации для всего диапазона оборотов. В таком случае задавайте обороты разделения выше макс. оборотов двигателя, и пользуйтесь только настройкой Частота 1

Усиление
Регулятор усиления сигнала с датчика

График
На графике есть настройка усиления, а также отображается порог детонации, текущий сигнал и история сигнала ДД с лога.

Усиление
Красная линия задает усиление сигнала ДД по оборотах. Чем выше обороты тем выше уровень сигнала, и усиление должно уменьшаться.

Текущий сигнал
Желтый маркер отображает текущее значение сигнала с ДД

Порог детонации
Зелена линия отображает заданый порог детонации

История
Синие точки показывают историю сигнала ДД.
Отображаются после загрузки лог-файла.

Калькулятор частоты детонации

Звук детонации - это звук удара по поршню. На частоту звука больше всего влияет диаметр поршня. Кроме основной частоты бывает хорошо слышно гармонику на частоте в 2 раза выше. В некоторых случаях лучшие результаты дает настройка фильтра на гармонику (удвоеную частоту детонации).

Примерный спектр детонации

Откат угла зажигания

Порог детонации
Задает порог, выше которого сигнал с датчика считается детонацией.
Порог отображается на графике зеленой линией.

Откат
Задает скорость отката УОЗ, в градусах на 1 вольт превышения порога детонации, а также максимально возможное значение отката.
К примеру если откат 0.5 гр/такт, то при превышении порога детонации на 1 вольт произойдет откат УОЗ на 0.5 градуса. При превышении порога детонации на 0.5 вольта произойдет откат на 0.25 градуса.

Восстановление
Задает скорость восстановления УОЗ после отката.
Если детонация не наблюдается, то УОЗ будет возвращаться в норму с заданым шагом.

Выбор датчиков по цилиндрам

Здесь задается соответствие между выходами COILx и датчиками детонации.
Вы задаете какой из датчиков должен использоваться для прослушивания конкретного выхода на катушку.

Детонация по цилиндрам

Алгоритм отслеживает и подавляет детонацию по каждому цилиндру отдельно.
В этом окне вы можете увидеть статистику - какой из цилиндров больше всего детонирует.
Затем можно принимать меры - например скорректировать УОЗ в минус на детонирующем цилиндре, или обогатить в нем смесь.

Способ настройки датчика детонации

Проверка работоспособности датчика

1. Подключите датчик детонации.
2. Установите частоту детонации 5.12 кГц
3. Включите тест Тахометр/ДД
4. Постучите по датчику
5. Следите за показаниями уровня детонации - они должны реагировать на стук по датчику

Базовая настройка

1. Настройте частоту детонации.
2. Установите максимальное усиление
3. Настройте параметры отката зажигания:
Порог детонации 4В
Откат 1 гр/такт, макс. 5гр
Восстановление 0.13 гр/такт
4. Нарисуйте кривую усиления как на рисунке

Калибровка датчика по оборотам

1. Прогрейте полностью двигатель.
2. Отрегулируйте общее усилени так чтобы сигнал на ХХ был на уровне 2..2.5 вольт
3. Медленно наберите обороты до максимальных. Следите чтобы сигнал ДД на всех оборотах держался в зоне 2..2.5 вольт. При необходимости регулируйте кривую усиления.
4. Проведите пробную поездку без детонации, и при необходимости подрегулируйте кривую усиления.

При правильной настройке лог должен выглядеть вот так. Основная масса синих точек должна быть на уровне 2-3 вольт.

Советы по настройке

Оптимальный УОЗ не всегда лежит на границе детонации.

Правильная настройка состоит в том чтобы детонации не было вообще. Для этого и нужен датчик, чтобы во время настройки видеть детонацию, которую плохо слышно ухом. А потом, при эксплуатации, ДД всего лишь аварийный датчик, подавляющий детонацию если она вдруг возникнет по каким-либо причинам.

Поэтому для точной отстройки сначала тщательно калибруем датчик. Затем заливаем нужное топливо, и катаем лог во всех режимах. Потом открываем лог, ищем точки с детонацией с помощью анализатора лога, и настраиваем УОЗ и смесь до полного подавления детонации.


Наполнение

Карта наполнения
Задает коэффициент наполнения цилиндров в зависимости от оборотов и нагрузки на двигатель.

Коэффициент наполнения - это процент попавшего в цилиндр воздуха от максимально возможного. Отображает эффективность работы двигателя в целом.

Если вы начинаете настройку с нуля - устанавливайте ниже 50 кПа значение 40, выше 50 кПа значение 100.


Смесь

Карта смеси

Задает желаемое значение смеси в зависимости от оборотов и нагрузки на двигатель.

Нормальная смесь - 14.7 (Стехиометрический состав)
Обедненная смесь 15-16 (Экономия топлива, большая температура горения)
Обогащенная смесь 10-13 (Макс. мощность)

См. также индикатор смеси

Лямбда-контроль

Обеспечивает автоматическую корректировку времени впрыска по показаниях лямбда-зонда.

При использовании узкополосного ЛЗ лямбда-коррекция работает только в ячейках со значением 14.7. При переходе рабочей точки в другие ячейки запоминается последнее значение коррекции. Поэтому для правильной работы лямбда-контроля на узкополосном ЛЗ нужно по всей карте (кроме мощностных режимов) устанавливать цифру 14.7

Скорость узкополосного ЛЗ
Задает скорость регулировки при использовании узкополосного лямбда-зонда. Скорость подбирается так чтобы не было пиления времени впрыска и раскачки смеси и оборотов на всех рабочих режимах.

Настройки PID-регулятора
Задают параметры регулятора при работе по широкополосному ЛЗ. Используйте настройки по умолчанию.

Адаптация

На горячем двигателе медленная коррекция по лямбде сохраняется в таблице по нагрузке и оборотам. Это позволяет автоматически подстраивать карту наполнения в процессе эксплуатации автомобиля.

Вы можете просмотреть или обнулить адаптацию.
Адаптация строится отдельно для обеих наборов калибровок.

Ограничение смеси на холодном двигателе

Вы можете запретить обеднение смеси больше указанного значения. Это стабилизирует работу холодного двигателя, и вместе с тем позволяет установить экономичные настройки смеси на прогретом двигателе.

Если температура ниже указаной - смесь не будет беднее указаного значения.


Фаза
Карта фазы впрыска

Задает начало впрыска в градусах относительно ВМТ начала такта впуска.
Нолем считается момент ВМТ начала такта впуска

Ноль - начало впрыска в положении ВМТ
Больше ноля - начало впрыска после ВМТ
Меньше ноля - начало впрыска до ВМТ

Импульс на форсунку подается с учетом задержки открытия форсунки . Таким образом начало подачи топлива не зависит от задержки открытия форсунки.

Индикатор фазы впрыска

Индикатор отображает впрыск топлива относительно окна открытия впускного клапана. Вокруг индикатора нанесены обозначения ВМТ и НМТ, а также соответствующие им углы поворота коленвала.

ВМТ 0/720 - это ВМТ начала такта впуска, которое считается нолем.

На индикаторе вы можете наглядно видеть как время впрыска бензина ложится на время открытия впускного клапана.

Лаг форсунки
Розовым сектором обозначено время задержки открытия форсунки

Впрыск топлива
Вишневым сектором обозначено время впрыска топлива

Впускной клапан
Зеленым сектором обозначены углы открытия и закрытия впускного клапана. Для правильного отображения вам нужно задать актуальные углы открытия и закрытия впускного клапана в параметрах Откр. и Закр. Эти параметры не влияют на рассчеты. Они сделаны для визуального контроля фазы впрыска.


Форсунка
Калибровка форсунок

Лаг форсунки

Лаг форсунки = время_открытия_форсунки - время_закрытия_форсунки.

Чем меньше напряжение в бортсети, тем больше времени нужно форсунке для открытия. Точность настройки этой таблицы напрямую влияет на точность рассчета времени впрыска. Некорректные значения лага форсунки вызывают раскачку оборотов на ХХ, которую ничем не удается компенсировать.

Если используется два ряда форсунок, то лаг первого ряда вычисляется с набора калибровок 1, соответственно лаг второго ряда - с набора калибровок 2.

Коррекция лага форсунки по времени впрыска
Если время впрыска меньше чем (2 * время_открытия_форсунки) - форсунка работает в нелинейном режиме. При этом меняется лаг форсунки, и возникает ошибка в подаче топлива. С помощью этой таблицы можно скорректировать смесь на малом времени впрыска, например при переключении из попарного режима в фазированный и наоборот.

Множитель времени впрыска
Регулирует общее время впрыска. Предназначен для подстройки под конкретные форсунки. При замене форсунок и/или изменении давления в рампе достаточно отрегулировать множитель по показаниях лямбды.

Аддитивная коррекция
Добавляет фиксированное значение к времени впрыска. Предназначена для быстрой подгонки карты наполнения под такой же мотор на другом авто.

Мин время впрыска при 14вольт
Задает время впрыска, ниже которого форсунка не открывается. Настройка полезна для больших и медленных форсунок (например газовых), а также при настройке обеднения для устранения провалов.

Фиксированное давление в рампе
Включает режим регулятора давления топлива с постоянным давлением (без вакуумного регулярования). Коррекция расчитана на наиболее распространенное давление 4бар.

Выровнять карту наполнения
Выравнивает пиковое значение наполнение до уровня 100. При этом пересчитывается множитель форсунки.

Драйвер форсунок
Включает ШИМ-драйвер низкоомных форсунок
(при условии что драйвер установлен в блоке)

Импульс открытия
Задает длительность импульса открытия форсунки.
Обычно это значение указано изготовителем.

Метод подбора:
- установите достаточно большое время, например 5мс
- уменьшайте значение пока двигатель не начнет работать нестабильно. Это критическое значение.
- добавьте 20-30% к полученому критическому значению

ШИМ удержания
Регулирует ток удержания форсунки. Для подбора значения - подключите измеритель тока последовательно форсунке №1, включите тест ШИМ , и подберите значение для получения паспортного значения тока удержания (обычно 1-2А)

Газовые коррекции
Включает коррекции впрыска газа. Используются датчики температуры и давления газа .

Температура газа
Температура газа в газовой рампе

Диф. давление
Это разница давлений до и после газовой форсунки.
Диф_давление_газа = Абсолютное_давление_газа - Абсолютное_давление_в_коллекторе

Расход топлива

Для расчета расхода топлива нужно задать производительность форсунки.
Если датчика скорости нет - будет учитываться только общее количество израсходованного топлива в литрах и мгновенный расход в л/час.

Точная настройка лага форсунки

Способ 1 (попарный - фазированный режим)
Отключите лямбда-контроль . На ХХ переключайтесь между попарным и фазированным режимами впрыска. Если смесь меняется при переключении - подбирайте лаг форсунки пока смесь не будет держаться стабильно.

Этот способ работает только на относительно больших временах впрыска, как минимум в 2 раза больше времени открытия форсунки.

Способ 2 (переключение смеси)
1. Отключите лямбда-контроль , задайте обороты ХХ 1200-1500.
2. Задайте богатую смесь в карте смеси (11-12). Отрегулируйте наполнение так чтобы реальная смесь была равна целевой
3. Задайте максимально бедную смесь, при которой двигатель стабильно работает (как правило 16-17). Отрегулируйте лаг форсунки так чтобы реальная смесь была равна целевой.
4. Повторяйте пункты 2-3 пока не добьетесь максимально точного попадания реальной смеси в целевую.


Ряды форсунок
Общие

Режим переключения рядов
Задает режим переключения рядов форсунок.
См. способы подключения второго ряда

Откл.
Ряды форсунок не переключаются, всегда используются настройки форсунки и лага из набора №1

Автопереключение бензин/газ
Включает режим автопереключения, как на обычном ГБО.
Бензин - набор калибровок №1, газ - набор №2.
Для бензина используется настройка форсунки из набора №1, для газа - из набора №2

По настройках выходов Рампа1/Рампа2
Вы настраиваете обороты переключения в настройках выходов , задаете отдельные правила для рампы1 и рампы 2.
Для ряда 1 используется настройка форсунки из набора №1, для ряда 2 - из набора №2

Вместе с калибровками
Ряды форсунок переключаются вместе с наборами калибровок по внешнему входу
Для ряда 1 используется настройка форсунки из набора №1, для ряда 2 - из набора №2

Второй ряд форсунок на INJ5-8
EMS-2 на 4-цилиндровом двигателе позволяет подключить второй ряд форсунок (или газовые форсунки) на четыре свободных выхода INJ5-INJ8.

Автопереключение газ/бензин

Здесь настраиваются параметры автопереключения газ/бензин
Запуск происходит на бензине, по достижению указаной температуры включается газовый клапан , и за пару секунд мотор переключается на газ.
Когда давление газа падает ниже 40кПа - мотор переходит на бензин.
Для индикации состояния используется индикатор газ/бензин

Т перехода на газ
При прогреве до указаной температуры мотор переходит на газ

Довпрыск бензина при загрузке газовых форсунок выше
Если загрузка форсунок поднимается выше указаного значения, бензиновые форсуноки включаются в параллель газовым

Довпрыск бензина при оборотах выше
Если обороты поднимаются выше указаного значения, бензиновые форсуноки включаются в параллель газовым


Коррекции
Коррекция впрыска по Т двигателя

Таблица задает дополнительное обогащение впрыска по температуре. Также к этой таблице привязаны настройки пуска двигателя.

Как правило выше 30-40 градусов двигатель устойчиво работает на стехиометрии. Ниже этой температуры обычно требуется дополнительное обогащение.

Коррекция топлива по цилиндрам

Работает только на фазированном впрыске
Задает дополнительную коррекцию отдельных цилиндров.
Под цифрами 1-8 подразумеваются выходы Inj1-Inj8

Расчет Т топливного заряда

Таблица задает правила смешивания температур впуска и двигателя для расчета температуры топливного заряда.

В таблице задается удельный вес температуры воздуха (в процентах) в расчете Т заряда.

Пример настроеной таблицы

На малых расходах воздуха (на ХХ) Т заряда расчитывается из 15% температуры воздуха и 100 - 15 = 85% температуры двигателя.
На больших расхода воздуха (газ в пол) Т заряда расчитывается из 90% температуры воздуха и 100 - 90 = 10% температуры двигателя.

Начинайте со значений по умолчанию. Корректируйте значения в случае когда при изменении температуры двигателя или впуска смесь уплывает от целевой.
При правильно настроеной таблице целевая смесь держится при любых условиях уже начиная с 20-30 градусов температуры двигателя.

Принцип расчета впрыска по температуре топливного заряда

Температура топливного заряда - это температура смеси, которая попадает в цилиндр на такте впуска.

Чем выше температура заряда тем меньше содержание кислорода, и необходимо подавать меньше топлива. Поэтому в жаркую погоду мощность двигателя падает.

Температура заряда расчитывается из двух величин: температуры двигателя и температуры воздуха перед дросселем.

Проходя по впускному тракту воздух нагревается от стенок. Степень нагрева зависит от скорости воздуха и от температуры стенок впускного тракта.

Чем меньше скорость воздуха на впуске, тем он больше нагревается. Температура заряда становится близкой к температуре двигателя.

Если скорость воздуха достаточно большая - он почти не успевает нагреваться. Температура заряда почти равна температуре воздуха перед дросселем.


Переходные режимы
Здесь настраивается уровень обогащения/обеднения на переходных режимах. Далее в тексте для удобства используется только слово "обогащение".

Обеднение

Здесь настраиваются параметры обеднения при уменьшении давления.

Таблица
Задает общий уровень обеднения по оборотам.

Длительность
Задает длительность работы обогащения

Корр. по температуре
Уменьшает уровень обеднения на холодном двигателе

Обогащение

Уровень
Задает общий уровень обогащения

Длительность
Задает длительность работы обогащения

Корр. по температуре
Увеличивает уровень обогащения на холодном двигателе

По дросселю

Компенсирует эффекты наполнения/опустошения ресивера при изменении положения дроссельной заслонки.
Настраивается с помощью высокоскоростного ШДК. Сначала нужно настроить обогащение/обеднение, потом подровнять смесь в переходных режимах по дросселю.

Способ настройки

Обязательно нужна полностью настроеная карта наполнения.

Начинаем с настроек по умолчанию и полностью прогретого двигателя.
Устанавливаем коррекцию по дросселю в ноль.

1 этап
Едем на 3-4 передаче при постоянной скорости

Плавно нажимаем на газ и фиксируем педаль. Нажимать педаль следует плавно, без рывка. Следим за смесью.
Регулируем обогащение так чтобы точно держалась целевая смесь, без скачков в богатую или бедную. Допускается кратковременное обеднение при начале движения педали. Не должно быть переобогащения.

Плавно отпускаем педаль, но не полностью, а до 30-40 кПа. Отпускать педаль следует плавно, без рывка. Следим за смесью
Регулируем обеднение так чтобы точно держалась целевая смесь, без скачков в бедную. Допускается кратковременное обогащение при начале движения педали. Не должно быть переобеднения.

Повторяем эту процедуру для нескольких значений оборотов, чтобы выстроить карту по оборотах.

2 этап
Сбрасываем газ с 50-60 кПа до почти полного закрытия, чтобы дроссель оставался открытым на 1-2%. Не отпускаем педаль полностью!

Регулируем обеднение по оборотам чтобы не допускать провалов в работе двигателя.

Помогает бороться с провалами также настройка минимального времени впрыска . Ее
устанавливаем примерно в половину рабочего времени впрыска на ХХ.

3 этап
При правильной настройке остается небольшой провал смеси при резком нажатии/отпускании педали. Его нужно скомпенсировать коррекцией по дросселю. Плавно увеличиваем коррекцию до устранения провала. Здесь уже можно газовать резко. Следите чтобы не было переобогащения.
Затем проделываем то же самое с обеднением по дросселю. Следим чтобы не было рывков-провалов при отпускании газа.


Пуск

Пуск/ПХХ
Пуск

Пусковые обороты
Это обороты, ниже которых работает стартер. Их необходимо устанавливать на 30-40 оборотов выше чем максимальные обороты стартера.

Время впрыска на пуске
Базовое время, с которого начинается запуск двигателя. Это значение работает ниже пусковых оборотов. Во время прокрутки стартером время впрыска постоянно уменьшается, чтобы не залить мотор бензином.

Режимы впрыска на пуске:
Режим впрыска (Параметры-основные) | Четное количество цилиндров | Нечетное количество цилиндров
Моно | моно | моно
Попарный | попарный | моно
Фаза "Пуск в фазированном режиме" ОТКЛ | попарный | моно
Фаза "Пуск в фазированном режиме" ВКЛ | фазированный | фазированный

Обогащение
Степень обогащения при низких температурах.
Среднее рабочее значение 50

Впрыск при включении
Одновременный впрыск всех форсунок при включении зажигания. Облегчает запуск двигателя. Подбирается экспериментально.
Примерное значение - от одного до двух величин времени впрыска на пуске

Позиция РХХ на пуске
Процент открытия РХХ ниже пусковых оборотов.

Позиция РХХ после пуска
Процент открытия РХХ с которого начинается регулирование ХХ после того как двигатель завелся. Этот параметр регулирует подьем оборотов после запуска.

Доп. откр. РХХ на пуске
Степень дополнительного открытия РХХ при низких температурах. Рассчитывается относительно карты коррекции впрыска по температуре.
Среднее рабочее значение 50

После пуска

Уровень обогащения
Работает после того как двигатель превысил пусковые обороты. Со временем обогащение плавно уменьшается к нулю.
Нужно для того чтобы холодный двигатель не глох сразу после запуска.
Среднее рабочее значение 40

Длительность обогащения
Задает длительность работы обогащения после пуска. Стандартное значение 100

Метод настройки пуска

Настройка горячего пуска

Необходимые условия для настройки:
Карта наполнения и смесь на низких оборотах приблизительно настроены
Двигатель полностью прогрет

Способ настройки
Установите пусковые обороты выше максимальных оборотов стартера.
Установите обогащение пуска = 50, обогащение после пуска = 20
Подберите время впрыска на пуске и положение РХХ на пуске чтобы мотор стабильно схватывал.
Обогащение после пуска надо увеличивать, чтобы убрать провал оборотов после пуска. Во время работы обогащения после пуска целевые обороты ХХ немного увеличиваются для поддержания холостого хода. Настраиваете так чтобы повышенные обороты придерживались 1-2 сек после запуска.
Положением РХХ после пуска отрегулируйте желаемый подьем оборотов после запуска. Для этого надо чтобы ПИД РХХ уже был настроен.

Настройка холодного пуска

Необходимые условия для настройки:
Горячий пуск полностью настроен
Обогащение по температуре настроено
Двигатель холодный (лучше всего настраивать с утра)

Способ настройки
Подберите Доп. откр. РХХ на пуске и обогащение пуска чтобы мотор стабильно заводился
Если мотор схватывает и сразу глохнет- увеличьте обогащение после пуска
Положением РХХ после пуска отрегулируйте желаемый подьем оборотов после запуска. Для этого надо чтобы ПИД РХХ уже был настроен.
Проверьте и подкорректируйте настройки горячего пуска.


Выходы
Парметры ШИМ

Здесь назначаются функции ШИМ-выходов.

Частота, Гц
Задает частоту работы ШИМ

Инверсия
Инвертирует выход ШИМ

Режимы ШИМ:

РХХ
Для подключения индуктивного РХХ. Частота 75-100 Гц
Чтобы подключить двухобмоточный РХХ, задайте режим РХХ для спареных каналов ШИМ, и в одном из них включите инверсию.

Вестгейт
Для подключения соленоида вестгейта. Частота 20-40 Гц

VVT1 / VVT2
Для подключения соленоида изменения фаз ГРМ. Частота 150 Гц

Адсорбер
Для подключения клапана продувки адсорбера бензобака

Тахометр
Позволяет получить произвольную частоту импульсов для подключения нестандартного тахометра

Ручной
Можно вручную задать скважность ШИМ

Прог 1
Программируемый ШИМ 1

Прог 2
Программируемый ШИМ 2

Прог 1 * Прог 2
Перемножение результатов обеих программ. Позволяет задать сложную характеристику по двух параметрах одновременно

Программируемые режимы Прог 1 / Прог 2:

Здесь вы задаете параметр, по которому будет расчитываться ШИМ,
крайние значения параметра,
% скважности ШИМ при крайних значениях

Если флажок off установлен, то при выходе за крайнее значение скважность будет устанавливаться в 0%. Иначе будет удерживаться заданная скважность ШИМ

Тахометр
Позволяет генерировать сигнал тахометра с произвольной частотой, от 0 до 200% от стандартного значения.

Ручной
Можно задать скважность вручную

Силовые выходы

В блоке есть несколько настраиваемых выходов. Их количество и возможности зависят от аппаратной версии блока .

После подключения к блоку вкладка "Выходы" показывает актуальные настройки для конкретной версии блока.

Выходам можно назначить названия (длиной до 8 букв), которые постоянно хранятся в блоке и не стираются после обновления прошивки. Для ввода названия щелкните по вкладке выхода.

Инверсия
Инвертирует состояние выхода. Если выход был активным - становится неактивным, и наоборот.

Только на заведенном двигателе
Выход активируется только на работающем двигателе. На остановленном двигателе выход всегда отключен, независимо от заданых условий.

Откл. при полном дросселе
Отключать выход если педаль полностью нажата

Дополнительное условие
И - активно, если выполняются оба условия одновременно
ИЛИ - активно, если выполняется одно или два условия.
Искл. ИЛИ - активно, если выполняется только одно из условий, но не два одновременно
Коррекция РХХ - изменение положения РХХ при включении и отключении выхода. Подбирайте значение так чтобы устранить колебания оборотов ХХ при включении/отключении нагрузки.

Задержка вкл/откл
Можно задавать задержки включения и отключения выходов.
Задержка вкл - после срабатывания условия включение выхода задерживается на заданое время
Задержка откл - после отключения условия выход поддерживается активным в течении заданого время

Описание функций выходов

Большинство функций работают по простых правилах: вы задаете пороги включения и отключения. Выход активируется согласно заданых условий.

Есть два варианта установки значений:

1. Вкл > Выкл.
Например: Вкл = 95 градусов, Откл = 90 градусов. Выход включится если температура>95 градусов, и отключится когда температура <= 90.

2. Вкл < Выкл.
Например Вкл = 3000об, Откл = 4000об. Выход включится, если 3000 < обороты <= 4000.
Некоторые функции работат по специальных правилах. Они описаны ниже.

Бензонасос
Задержка откл. задает время работы бензонасоса после остановки двигателя или при включении зажигания.
Если задержка вкл не равна нулю - бензонасос не включится сразу после включения зажигания.

Метанол
Выход активируется по указаных значения давления. Вместе с активацией выхода применяется дополнительная коррекция

Детонация
Выход активируется когда работает откат УОЗ по детонации

Форсунки ряд 1
Форсунки ряд 2
Режимы предназначены для управления двумя рядами форсунок. Выходы подключаются на реле подачи питания на ряды форсунок.

Алгоритм переключения рядов форсунок выбирается на вкладке Впрыск - Ряды форсунок

Кондиционер
Режим предназначен для управление муфтой компрессора кондиционера.
При включении кондиционера включаются выходы Вентилятор и срабатывает коррекция РХХ
Для уменьшения ударной нагрузки отрегулируйте разные задержки включения кондиционера и вентиляторов

Алгоритм управления активируется с помощью кнопки включения и датчика давления в кондиционере. В настройках входов выберите каналы для подключения кнопки и/или датчика. Помните о том что некоторые входы имеют встроенную подтяжку, их нужно замыкать на землю чтобы отключить. Смотрите описание вашей версии ЭБУ .

Если задано оба входа (кнопка и датчик) - кондиционер включится если кнопка нажата и давление в заданных пределах.
Если задан только вход кнопки - кондиционер включится если кнопка нажата.
Если задан только вход датчика давления - кондиционер включится если давление в заданных пределах.

Если не хватает входов и у вас аналоговый датчик давления, который должен контролироваться ЭБУ - используйте только вход датчика давления. Кнопку включения кондиционера подключите так, чтобы она подавала питание на датчик давления. Тогда при выключенной кнопке нулевое напряжение на выходе датчика давления будет отключать кондиционер.

Пределы напряжения на датчике задаются в параметрах настраиваемого выхода. Есть два варианта настройки:
1. Вкл < Выкл. Например Вкл=2в, Выкл=4в. Если напряжение в диапазоне от 2 до 4 вольт - кондиционер будет включен.
2. Вкл > Выкл. Например Вкл=3в, Выкл=2в. Если напряжение превысит 3в - кондиционер включится, и будет работать пока напряжение не упадет ниже 2в.

Вентилятор
Настраиваются пороги вкл/откл по температуре двигателя.
Вентиляторы принудительно включаются при включении кондиционера.

Блок. стартера
Предназначен для управления реле, размыкающего цепь стартера.
Блокирует включения стартера на работающем двигателе, а также автоматически отключает стартер когда двигатель завелся.

Check Engine
Предназначен для подключения лампы Check Engine

Автозапуск
Подключается к реле стартера
Предназначен для автоматического запуска двигателя.
В настройках входов выберите канал для подключения кнопки. Помните о том что некоторые входы имеют встроенную подтяжку, их нужно замыкать на землю чтобы отключить. Смотрите описание вашей версии ЭБУ .
Алгоритм активируется кратковременным нажатием кнопки.

При неуспешном запуске выдерживается пауза, после чего предпринимается следующая попытка. Всего есть 3 попытки запуска, после чего алгоритм отключится.

Лампа Check Engine сигнализирует работу алгоритма запуска.

Газовый клапан
Используется для включения газового клапана при работе с ГБО. Газовый клапан активируется при переключении в режим газа.

Форсунки ряд1/ряд2
Для подключения реле рядов форсунок.
См. переключение рядов форсунок

Check Engine
Предназначен для подключения лампы Check Engine

Индикатор Газ/бензин
Индикация работы системы газ/бензин.
Включен - работа на газу.
Отключен - работа на бензине.
Медленное моргание - ожидание перехода на газ.
Быстрое моргание - закончился газ, работа на бензине

Трекшн
Индикация работы трекшн-контроля

Кнопка
Использует состояние кнопок . В параметре Вкл задается номер кнопки.


Входы
Функции аналоговых входов

Задает функции аналоговых входов.

Звездочкой обозначены входы с подтяжкой 2кОм к 5В

Датчик давления кондиционера
См. описание настраиваемых выходов , режим Кондиционер.

Второй датчик электронной педали
Предназначен для подключения второго датчика электронной педали газа. Первый датчик подключается на вход TPS

Давление газа
Для датчика давления газа в газовой рампе

Температура газа
Для датчика температуры газа в газовой рампе

Перекл. калибровок
Если напряжение на входе выше 2.5 вольт - переключается набор калибровок.

Автозапуск
См. описание настраиваемых выходов , режим Автозапуск.

Внешний ДАД
Используется внешний ДАД. См. настройку внешнего ДАД

Температура масла
Для датчика температуры масла в двигателе

Температура двигателя
Для датчика температуры двигателя

Температура воздуха
Для датчика температуры впускного воздуха

Функции цифровых входов

Задает функции импульсных цифровых входов DNO и DHx для подключения индуктивных датчиков или датчиков холла.

Датчик угла VVT1 / VVT2
Режим измерения угла поворота распредвалов

Датчик скорости 1a/1b
Подключение датчиков скорости ведомых колес. Эти датчики используется для измерения скорости автомобиля.
Если подключается только один датчик, следует использовать вход 1а.
a - левое колесо, b - правое

Датчик скорости 2a/2b
Подключение датчика скорости на КПП, или датчиков скорости ведущих колес.
При подключении двух датчиков скорости их показания усредняются.
Эти датчики используются для системы антипробуксовки.
Если подключается только один датчик, следует использовать вход 2а.
a - левое колесо, b - правое

Перекл. калибровок
Переключает наборы калибровок 1/2

Автозапуск
Включает автозапуск

Вкл. кондиционер
Вход включения кондиционера

Откл. трекшн
Отключает трекшн-контроль

Дисплей
Переключает дисплей

Лаунч-контроль
Активирует лаунч-контроль вручную, если не подключен датчик скорости

Круиз
Управление круиз-контролем

Тормоз
Сигнал нажатия педали тормоза

Сцепление
Сигнал нажатия педали сцепления

Давл. масла
Вход датчика давления масла для защиты двигателя

АКПП
Вход включения передачи на АКПП

Маркер
Маркер в логе для удобства поиска

Метанол
Датчик активации впрыска метанола

Кнопки

В блоке есть от 1 до 8 входов кнопок. Их количество зависит от аппаратной версии блока .

Вы задаете функцию каждой кнопки отдельно. Если задать одну и ту же функцию на несколько кнопок, то будет срабатывать только кнопка с наименьшим номером.

На блоках v1 есть только одих вход кнопки, но для них высвечивается два входа. Это сделано для возможности задать две функции на одну кнопку, например кондиционер + переключение калибровок.

Галка инвертирует положение кнопки.


Холостой ход
Обороты ХХ
Таблица задает желаемые обороты ХХ в зависимости от температуры двигателя.

Мин. положение
Устанавливает порог, ниже которого РХХ не закрывается. Настраивается на 100-200 оборотов ниже оборотов ХХ.

Подхват
Регулирует подхват оборотов при сбросе газа.

Ручное управление
Позволяет вручную задавать положение РХХ.
При установке в ноль ручное управление отключается.

Стабилизация углом зажигания
Задает уровни стабилизации ХХ при отклонении оборотов и по ускорению коленвала.

Отсечка ПХХ

Параметры отсечки топлива при движении на принудительном холостом ходу (отпущена педаль газа при движении на передаче)

Обороты
Это обороты, ниже которых возобновляется подача топлива.
Обычное значение 1200-1400 об/мин

Задержка отсечки
Это время после которого топливо будет отсекаться на оборотах близких к ХХ. Это нужно для устранения рывков при отпускании газа. С увеличением оборотов задержка автоматически уменьшается к нулю.

Коррекции

Здесь задаются коррекции РХХ при включении/отключении кондиционера/АКПП для устранения скачков оборотов при включении большой нагрузки

Для включенного кондиционера отдельно задаются обороты ХХ

В параметры Вкл и Выкл вписывается коррекция положения РХХ. Значения подбираются так чтобы включение и отключение кондиционера было незаметным.

Шаговый двигатель

Здесь вы можете включить режим шагового РХХ. При этом выходы STEP1-4 задействуются для подключения шагового двигателя РХХ.

Количество шагов

Задает количество шагов шагового регулятора.

Нужно устанавливать минимально необходимое для регулирования количество шагов, чтобы ускорить иницализацию.

При включении питания шаговый двигатель должен повернуться в закрытое положение, и затем обратно вернуться в рабочее. Чем меньше количество шагов, тем быстрее он это сделает. Желательно установить реле блокировки стартера, которое будет блокировать стартер пока не пройдет инициализация шагового двигателя.

Способ настройки РХХ

Это алгоритм настройки РХХ с нуля.

Настройка мин. положения

Минимальное положение устанавливает порог, ниже которого РХХ не может закрыться

Внимание! Некоторые РХХ (например Ауди) имеют аварийную позицию: в нулевом положении шторка приоткрыта. Затем, при увеличении положения шторка закрывается, и примерно начиная с 40% опять открывается. Это сделано для того чтобы при отсутствии управляющего сигнала двигатель не заглох.

1. На холодной машине (температура ниже 30гр) ручным управлением устанавливаем обороты на 100-200об ниже оборотов ХХ.
2. Записываем положение РХХ в "мин. положение при 30 гр"
3. Прогреваем машину до 90гр и ручным управлением устанавливаем обороты на 100-200об ниже оборотов ХХ.
4. Записываем положение РХХ в "мин. положение при 70 гр"
5. Если вы заметите что при эксплуатации машины РХХ упирается в мин.положение, а обороты все равно выше нормы, нужно уменьшить мин. положение чтобы дать регулятору больше простора для регулировки.

Настройка коэффициентов PID

Перед началом настройки
1. Прогрейте двигатель
2. Установите обороты отсечки ПХХ = 6000
3. Установите Kp=0 Ki=5 Kd=0

Настройка Ki
Это самый главный коэф. Он задает скорость регулировки оборотов при небольших отклонениях. Например вы включили кондиционер, обороты упали, и затем восстановились. Скорость, с которой регулятор будет поднимать обороты задает Кі.

1. Установите 800 в таблице оборотов ХХ и подождите пока обороты стабилизируются
2. Установите 1200 в таблице оборотов ХХ и подождите пока обороты стабилизируются
3. Повторяйте пункты 1-2 и добейтесь регулятором Кі того чтобы обороты устанавливались за 3-4 сек.

Настройка Kp
Этот коэф. ускоряет реакцию регулятора при больших отклонениях.

1. Установите 800 в таблице оборотов ХХ и подождите пока обороты стабилизируются
2. Установите 2000 в таблице оборотов ХХ и подождите пока обороты стабилизируются
3. Повторяйте пункты 1-2 и увеличивайте Кр до появления раскачки оборотов, нестабильности, и других нежелательных эффектов. Затем полученное значение Кр уменьшите вдвое.

Настройка Kd
Kd ограничивает скорость падения оборотов. Этот коэффициент мало влияет на работу РХХ, но может вызывать раскачку. Можете установить его в 0. Или при желании - увеличивать пока не начнется раскачка оборотов при перегазовке, и затем уменьшить в два раза.

Настройка подхвата
Эта настройка предназначена для того чтобы при сбросе газа РХХ подхватывал обороты заведомо выше нормы, и затем плавно опускал. Чем выше значение - тем выше подхват.

1. Настройте отсечку ПХХ
2. Газните и резко отпустите педаль газа
3. Подберите подхват так чтобы обороты плавно опускались на ХХ и никогда не проваливались ниже ХХ при любых вариантах прогазовок. Допускается небольшое, порядка 0.5 сек подвисание оборотов перед уменьшением к оборотам ХХ.


Наддув
Базовое положение соленоида
Таблица задает положение соленоида для достижения целевого давления в зависимости от оборотов двигателя

Целевое давление по оборотам
Таблица задает целевое давление наддува в зависимости от оборотов двигателя.

Ограничение давления по нажатию педали газа
Позволяет уменьшать давление наддува при неполном нажатии педали

Ограничение давления по ДТВ
Уменьшает давление при нагреве впускного воздуха

Мин давление наддува
Установите здесь наибольшее значение давления, которое развивает турбина при отключеном соленоиде. Это значение необходимо для правильной работы алгоритма.

Скорость регулировки
Задает скорость подстройки давления регулятором

Ограничение давления по передачам
Ограничивает целевое давление по передачах

Настройка наддува

Все настройки следует делать на максимально высоких передачах, желательно при движении в гору. Таким образом вы даете достаточно времени для достижения пикового наддува. Если нет такой возможности - настраивайте низкие обороты на 4-5 передачах, а высокие - как получается.
· Установите Скорость регулировки = 0,
· Установите ограничение давления по ДТВ и педали газа в максимальные значения, чтобы не мешали в настройке.

· Отключите соленоид вестгейта, сделайте заезд, запомните достигнутое давление наддува и введите в Мин давление наддува

· Задайте таблицу целевого давления. Значения должны быть реально достижимыми.

· Установите таблицу положения соленоида в 20. Постепенно добавляя значения, настройте так чтобы держался целевой наддув во всем диапазоне оборотов.
Если целевой наддув не достигается - следует откорректировать таблицу целевого наддува.

· Увеличивайте Скорость регулировки, пока не начнутся передувы и раскачки давления. Затем уменьшите скорость на 30-40%.

· Настройте желаемое ограничение давления по дросселю и ДТВ


Метанол
Эдесь настраивается коррекции при впрыске метанола, закиси азота, воды, и т.п.

Коррекции активируются по правилах настраиваемого выхода Метанол.

Также есть возможность подключить датчик на вход кнопки , который будет показывать исправность системы впрыска метанола. Например - датчик давления в системе впрыска метанола, или датчик уровня.
Если сигнал на входе отсутствует - значит впрыск не действует, и коррекция не будет активирована.

Коррекция топлива при впрыске метанола
Таблица задает % коррекции подачи топлива

Коррекция зажигания при впрыске метанола
Таблица задает угол коррекции зажигания

Целевая смесь при впрыске
Вы можете установить отдельное значение целевой смеси, которое будет использоваться при впрыске метанола


Трекшн/Лаунч

Трекшн / Лаунч-контроль
Лаунч-контроль

Предназначен для максимально быстрого старта с места.

Если установлен датчик скорости - активируется автоматически при нажатии газа в пол на стоящей машине. Если датчика скорости нет - включается кнопкой .

Функция удерживает заданые обороты отсечки и позднит зажигание для раскрутки турбины (если опция активирована). После начала движения или отпускания кнопки отсечка снимается, и вступают в действие настройки ограничения момента на старте.

Внимание! Лаунч-контроль приводит к агрессивному износу двигателя, турбины, трансмиссии!

Обороты отсечки
Задают обороты отсечки

Целевой наддув
Если включено - обороты отсечки удерживаются поздним зажиганием (30-40гр после ВМТ).
За счет этого турбиной нагнетается высокое давление. Также критически повышается температура выхлопных газов. Длительное использование этой функции приводит к перегреву и повреждению турбины.

Начальный угол
УОЗ, с которого начинается работа двигателя после отключения функции. Предназначено для уменьшения ударной нагрузки. Работает за счет занижения УОЗ, и плавного повышения до нормы.

Скорость подьема угла
Скорость, с которой увеличивается УОЗ после отключения функции.

Флет-шифт

Предназначен для переключения передач без сброса газа. Требует подключения концевика педали сцепления.
Если обороты выше оборотов отсечки, газ нажат до упора, и выжимается сцепление - обороты ограничиваются с помощью позднего зажигания, тем самым удерживая давление наддува. После отпускания педали сцепления УОЗ восстанавливается с заданной скоростью, чтобы уменьшить удар в трансмиссии и вероятность срыва колес в букс.

Обороты отсечки
Задают обороты отсечки

Начальный угол
УОЗ, с которого начинается работа двигателя после отключения функции. Предназначено для уменьшения ударной нагрузки. Работает за счет занижения УОЗ, и плавного повышения до нормы.

Скорость подьема угла
Скорость, с которой увеличивается УОЗ после отключения функции.

Трекшн-контроль

Работает с помощью управления электронным дросселем и/или углом зажигания.
При откате УОЗ следует внимательно следить за температурой выхлопных газов.

Активен
Задает скорость, выше которой активируется трекшн-контроль

Целевая пробуксовка
Процент пробуксовки, который старается поддерживать алгоритм. Обычно 10-15%

Быстрая регулировка
Плавная регулировка
Задает скорость работы алгоритма. Следует подбирать до получения наилучшего результата.
Начинайте с быстрой регулировки, добивайтесь надежного сброса тяги. Затем добавляйте медленную регулировку чтобы устранить рывки.

Откат УОЗ
Задает скорость отката УОЗ и максимально возможный угол отката.


Электронный дроссель
Индикаторы состояния

Связь ОК
Установлена связь с модулем управления дросселем

Конфигурация ОК
Модуль дросселя успешно откалиброван

Ошибка калибровки
Начальное положение дросселя не соответствует калибровке.
При детектировании этой ошибки дросель отключается.
Причины: неправильная калибровка или дроссель заклинил

Ошибки датчика дросселя
Периодические ложные показания датчиков положения дроссельной заслонки.
Проверьте проводку и разьемы, а также сигнал с датчиков с помощью осциллографа.

Отказ датчика дросселя
Критические расхождения в показаниях датчиков положения дроссельной заслонки.
При детектировании этой ошибки дросель отключается.
Проверьте проводку и разьемы, а также сигнал с датчиков с помощью осциллографа.

Ошибка позиционирования
Дроссель не может установить заданное положение.
При детектировании этой ошибки дросель отключается.
Причины: неправильная калибровка или дроссель заклинил.

Отказ силового драйвера
Силовая микросхема управления мотором дросселя определила ошибку и отключилась.
При детектировании этой ошибки дросель отключается.
Проверьте проводку и разьемы. Ищите короткое замыкание.

Ошибки датчика дросселя
Периодические ложные показания датчиков положения педали.
Проверьте проводку и разьемы, а также сигнал с датчиков с помощью осциллографа.

Отказ датчика дросселя
Критические расхождения в показаниях датчиков положения педали.
При детектировании этой ошибки дросель отключается.
Проверьте проводку и разьемы, а также сигнал с датчиков с помощью осциллографа.

Настройки

Ограничение открытия дросселя
Ограничивает открытие дроссельной заслонки значениями, которые указаны в таблице

В турбо-двигателе это ограничение действует пока давление ниже 100 кПа. При наборе давления ограничение плавно снимается. Таким образом уменьшается эффект турбо-ямы, набор давления происходит плавнее и быстрее.

Нелинейность дросселя
Задает степень нелинейности характеристики дросселя. Чем больше число, тем плавнее реакция дросселя на малых нажатиях педали.

Диапазон работы РХХ
Задает процент открытия дросселя, который соответствует 100% положения РХХ
Если установить 0, то можно подключить отдельный РХХ.

Второй датчик педали
Задает калибровку второго датчика педали.
Выберите аналоговый вход датчика в настройках входов

Для калибровки:
- Отпустите педаль. Задайте напряжение 0%
- Нажмите педаль до упора. Задайте напряжение 100%

После сохранения значения могут незначительно измениться из-за внутреннего округления чисел.

Круиз контроль
Настраивает ПИД регулятор круиз-контроля

Калибровка

Адаптация
Запускает процедуру адаптации дросселя.

Калибровка датчиков
Рекомендуется оставлять в нулевом положении

Демпфер
Предназначен для плавного закрытия заслонки в околонулевом диапазоне.
Когда дроссель закрывается ниже порога, скорость движения заслонки принудительно замедляется.

Рекомендуемые значения: порог = 5%, скорость = 1.

Настройки PID-регулятора
Как правило значения по умолчанию работают хорошо.


VVT
Вкладки VVT прячутся если не активирован соотв. режим ШИМ

Если вы используете индуктивный датчик распредвала, убедитесь что угол измеряется верно. Для этого отключите разьем от клапана, и сделайте прогазовку до отсечки. Угол поворота распредвала должен быть одинаковым на всем диапазоне оборотов. Если угол меняется, нужно изменить полярность подключения датчика или включить инверсию.

Калибровка угла
Калибрует измерения угла поворота распредвала

Диапазон
Максимально возможный диапазон поворота распредвала

Карта угла VVT

В карте значения задаются в градусах поворота коленвала.
Увеличение значений поворачивает распредвал в сторону более раннего открытия клапанов.
В карте должны быть плюсовые значения не меньше 2-3 градуса, чтобы не заклинивать регулятор в крайнем положении.

На малых нагрузках, ниже 60 кПа рекомендуется устанавливать одинаковое значение угла для впускного распредвала. Это значительно улучшает стабильность работы в этой зоне.

Начальная настройка
Включите ШИМ VVT с частотой 200-300гц в настройках выходов
PID регулятор - по умолчанию
Установите всю карту VVT в 5 градусов
Снимите разьем с соленоида - распредвал повернется в максимально позднее положение
Подберите калибровку угла так чтобы текущий угол отображал 0...1 градус
Верните разьем на место. Распредвал должен развернуться в положение 5 градусов.
Если распредвал стоит в нулевом угле - включите инверсию ШИМ.

Настройка PID регулятора
Для начала прогрейте масло в двигателе.
Установите Kp=0, Kd=0. Подберите Кі так чтобы распредвал устанавливался максимально быстро, но без перелета целевого положения.
Добавляйте Kp для ускорения регулирования, но следите чтобы не было перелетов. При необходимости уменьшайте Кі, подбирайте их значения в паре для максимально быстрого регулирования.
Добавляйте Кd пока не начнется раскачка положения, затем уменьшите значение в 2 раза.


Основные
Внимание! Некоторые опции после изменения требуют перезагрузки блока. Они отмечены звездочкой. Еслы вы изменили такую опцию - после сохранения подождите 2 секунды, затем отключите питание блока на 5 секунд.

Базовые настройки

Количество цилиндров
Задает количество цилиднров в двигателе.

Начало отсчета с катушки
Определяет номер выхода на катушку, которая должна подать искру после прохождения метки первого цилиндра.

Режим зажигания / Режим впрыска
Моно - все выходы работают одновременно.
Попарный - каждый выход работает на два цилиндра одновременно.
Фазированный - каждый выход работает на отдельный цилиндр.

Режимы можно переключать "на лету".
Датчик фазы активируется, если включен фазированный режим зажигания и/или впрыска.
Попарный режим невозможен для нечетного количества цилиндров.

Режим расчетов
ДАД - расчет нагрузки по ДАД. Подходит для турбо-двигателей.
ДПДЗ - расчет нагрузки по ДПДЗ. Используется редко, для многодроссельного впуска, когда смешанные режимы плохо работают. Только для атмо-двигателей.
ДПДЗ+ДАД - расчет нагрузки по обеих датчиках. Только для атмо-двигателей.
ДПДЗ+ДАД2 - расчет нагрузки по обеих датчиках. Только для атмо-двигателей.

См.также Настройка режимов ДАД+ДПДЗ

Шкала давления
Задает максимальное давление на картах зажигания и топлива.
Изменение этого значения требует полной перестройки карт зажигания и впрыска.
Значение следует выбирать с запасом.

Энергосбережение
Отключает каналы ШИМ и электронный дроссель при длительном простое

ДПКВ

Количество зубьев на шкиве
Задает количество зубов на шкиве коленвала.
Это значение учитывает пропущеные зубья и не учитывает двойные.
Например для шкива 60-2 (58 зубов + два отсутствует) нужно указывать значение 60. А для шкива 6+1 (7 зубов, один из них двойной) нужно указывать значение 6.

Количество зубьев от метки до ближайшей МТ
Задает положение ВМТ двигателя.

Способ расчета:
1. Установите первый зуб после метки на шкиве коленвала напротив датчика
2. Проверните коленвал по ходу до ближайшей мертвой точки. Посчитайте сколько зубов прошло возле датчика.

Пропущеных зубов
Задает количество пропущеных зубьев на шкиве.
Эта настройка актуальна только для прошивки типа 'с'

Коррекция нулевого угла
Предназначена для точной подстройки положения ВМТ. Грубая настройка осуществляется количеством зубов от метки до МТ.

Коррекция пускового угла
До 400 об/мин искра расчитывается по зубьях, и идет в момент ВМТ. Эта опция позволяет сдвинуть момент искры в плюс или минус на заданное число зубов.

Инверсия ДПКВ
Программно инвертирует полярность сигнала ДУИ/ДПКВ.

ДПКВ на входе DH5
Меняет местами входы UI / DH5. Используется для подключения датчика холла в качечтве ДПКВ

ДФ

Датчик фазы активируется если режим впрыска и/или зажигания переключен в положение "Фаза".

Количество зубов для синхронизации
Задает режим синхронизации по датчику фазы.

0 - значение ДФ считывается в момент считывания метки ДПКВ. Самый помехоустойчивый и надежный режим, игнорируются все помехи сигнала ДФ. Необходимое условие - метка ДПКВ должна быть посредине импульса ДФ. Не подходит для работы с VVT

1 и больше - идет подсчет количества импульсов ДФ между метками шкива коленвала. Если количество импульсов совпало с заданым - определяется первый цилиндр. Этот режим более чувствителен к помехам.

Инверсия ДФ
Программно инвертирует полярность сигнала.

Пуск в фазированом режиме
По умолчанию запуск двигателя происходит в попарном режиме без синхронизации с ДФ. Это ускоряет запуск двигателя. После запуска система тестирует ДФ, и в случае корректной работы датчика переходит на фазированный режим. При отказе ДФ система переключается обратно на попарный режим, и отображает ошибку
Включение этой функции позволяет запуск только после синхронизации с датчиком фазы. Функция принудительно включается на нечетном количестве цилиндров.
Функцию есть смысл использовать на больших/медленных форсунках, которые нестабильно работают в попарном режиме.

Вход датчика
Задает вход по которому считывается сигнал фазы

Название блока

Выберите название для вашего ЭБУ. Это может быть название машины, ник на форуме, или другое название, которе будет отличать ваш ЭБУ от других.
Краткое название подставляется в названия файлов и названия папок при сохранении. Это упорядочивает хранение данных на диске.

Важно! Не используйте спецсимволы, знаки препинания, кириллицу, и т.п. Пробелы заменяйте на знаки "-" или "_".


Основные датчики
Калибровка датчика температуры двигателя
Таблица задает калибровку датчика температуры
Калькулятор позволяет расчитать всю таблицу по 3-х точках

Калибровка датчика температуры воздуха
Таблица задает калибровку датчика температуры
Калькулятор позволяет расчитать всю таблицу по 3-х точках

ДПДЗ

Напряжение 0% и 100%
Значения задают крайние положения датчика положения дросселя.
Значения необходимо задавать с запасом, особенно 0%. Например, если при отпущенной педали напряжение равно 1.530в, то следует указать значение повыше, например 1.6в. Это связано с тем что показания датчика плавают в некоторых пределах, что может вызвать ложные переходы с режима ХХ, или режим ХХ вообще не будет включаться.

Открытие дросселя при котором достигается 100 кПа
Значения в таблице указывают при каком положении дросселя в коллекторе достигается давление около 100 кПа.

Это очень важная калибровка, которая влияет на многие процессы в двигателе. Ее нужно очень тщательно настраивать.

Способ настройки
- Устанавливаем всю таблицу в 100%
- Включаем запись лога
- Разгоняемся на 3-4 передаче, быстро нажимая газ до достижения 100кПа и отпуская обратно. Делаем это много раз на разных оборотах.
- Смотрим лог, и находим точки положения дросселя, при которых давление достигает 96-100 кПа. Заносим эти значения в таблицу.

Внешний ДАД / Датчик давления газа
Расчитайте Смещение и Множитель с помощью калькулятора [image] или выберите стандартную калибровку из списка калькулятора.
В настройках входов укажите на какой вход подключен ваш датчик.

Усреднение
Задает уровень сглаживания показаний ДАД.

Лямбда-зонд

Широкополосный
Калибровка сигнала ШДК. Задаются значения смеси при напряжениях 0в, 2.5в, 5в.
Эти данные вы найдете в документации на ШДК.
В программе заданы значения для наиболее популярных ШДК.

Узкополосный
Уровень сигнала настраивается автоматически, под стандартный лямбда-зонд

Время прогрева
Задает период после пуска двигателя, во время которого игнорируются показания лямбда-зонда.


Дополнительные датчики
Калибровка датчика температуры масла
Таблица задает калибровку датчика температуры масла.
Калькулятор позволяет расчитать всю таблицу по 3-х точках
Вход датчика задается в настройках входов

Калибровка датчика температуры газа
Таблица задает калибровку датчика температуры газа для ГБО
Калькулятор позволяет расчитать всю таблицу по 3-х точках
Вход датчика задается в настройках входов

Датчик скорости 1 и 2

Задайте количество импульсов датчика на 1км пробега

Вольтметр

Калибровка вольтметра
Эта настройка позволяет откалибровать показания встроенного вольтметра.

Передачи

Задает коэффициенты для определения текущей передачи.

Процедура настройки: едете на передаче, и нажимаете кнопку с соответствующим номером передачи. Программа расчитает коэффициент. Если передача не существует - задайте значение 0.


Дисплей
Здесь задаются параметры, которые отображаются на дисплее.

Можно использовать два отдельных дисплея, или же один дисплей с переключением 2-х наборов информации с помощью короткого нажатия кнопки

Подключение дисплея описано здесь


Диагностика
Тест

Просушка свеч
На все свечи постянно подаются импульсы. Таким образом удается просушить слегка залитые свечи, а также проверить систему зажигания под нагрузкой. Нагрузка примерно равна работе двигателя на 5-6 тыс.об. и должна выдерживаться неограниченое время.
Если тест работает прерывисто - это значит что блок видит помехи на входе ДПКВ. На время теста закоротите между собой провода идущие с ДПКВ.

Тест катушки
Подаются кратковременные импульсы на заданный номер выхода COIL

Тест форсунки
Подаются кратковременные импульсы на заданный номер выход INJ

Фикс. УОЗ
Система зажигания работает с заданным УОЗ. Все другие настройки зажигания игнорируются.

Пусковой УОЗ
Система зажигания переходит в пусковой режим, искра формируется по зубьях. Момент подачи искры при этом будет гулять, потому что режим не предназначен для работы на оборота выше 400. При настройке стробоскопом ориентируйтесь на наиболее раннее положение метки.

Тахометр/ДД
Тест тахометра и датчика детонации. Тахометр генерирует импульсы около 2-3 тыс.об. При этом активируется датчик детонации, и вы можете проверить его работоспособность.
Цифра задает номер входа ДД

ШИМ форс.
Генерирует ШИМ на выходе заданой форсунки. Предназначен для настройки тока на форсунке. Включите тест и подберите настройки ШИМ для получения нужного тока удержания на форсунке.

Стробоскоп на выходе ТАСН

Выход ТАСН переключается в режим стробоскопа, и генерирует короткие импульсы, предназначенные для управления светодиодным стробоскопом .
Вы можете задать номер канала зажигания (COILx), который будет генерировать импульсы.

Проверка фазы впрыска
Если впрыск фазированный а зажигание - нет, стробоскоп все равно работает в фазированном режиме, что позволяет проверить фазировку впрыска.
Задайте в опциях стробоскопа номер канала, который подключен к первому цилиндру и активируйте стробоскоп. Дальше вам нужно, чтобы стробоскоп показал метку ВМТ 1-го цилиндра на распредвале. Если метка не совпадает - изменяйте настройку "начинать отсчет с цилиндра" в основных параметрах .

Анализатор
Это аналог многоканального осциллографа. Предназначен для диагностики датчиков коленвала. Записывается 8 каналов. Три из них - это сигналы ДФ, ДУИ, ДНО/ДПКВ. Остальные 5 - это сигналы на катушки или на форсунки по выбору.

Для начала нажмите кнопку Запись. Связь с блоком пропадет. В это время блок передает данные анализатора с высокой скоростью, которые записываются в файл.
Для остановки нажмите еще раз кнопку Запись. Связь с блоком восстановится.
Для просмотра откройте лог-файл analyzer_xxxxxx

Счетчики
В энергонезависимой памяти блока сохраняются различные счетчики - ошибок, минимальных и максимальных значений. Вы можете их прочитать или обнулить.

Все данные из блока
В этом списке находятся полностью все данные, которые отдает блок.


Защита двигателя
Ограничитель оборотов

Макс. обороты
Обороты отсечки топлива

Звук отсечки
Эта настройка меняет звук отсечки. Подбирайте на свой вкус.

Опережение отсечки
Алгоритм должен отключать топливо раньше чем будут достигнуты обороты отсечки. В противном случае двигатель по инерции раскручивается выше оборотов отсечки.
Эта калибровка регулирует алгоритм опережающей отсечки. Значение подбирается так чтобы при газовании на нейтралке обороты не поднимались выше отсечки.

Давление

Прикрытие дросселя
При превышении давления дроссель прикрывается. Это позволяет плавно и почти незаметно ограничить давление.
Ограничение плавно нарастает от нижнего порога до верхнего.

Откл. топлива
При превышении давления отключается топливо. Подача топлива возобновляется при существенном падении давления. В результате получается ощутимая отсечка, которая сигнализирует о проблеме с регулировкой далвения наддува.

Температура выхлопа

Коррекция смеси
Задает процент коррекции смеси при превышении заданной температуры выхлопа.
Коррекция плавно нарастает от нижнего порога до верхнего.

Ограничение наддува, оборотов или дросселя
Задает процент ограничения при превышении заданной температуры выхлопа.

Если установлен электронный дроссель - ограничивается положение дросселя. Иначе - ограничиваются обороты.

Наибольшее ограничение оборотов - 50% от максимальных.

Ограничение плавно нарастает от нижнего порога до верхнего.

Отключение топлива

По смеси
Срабатывает отсечка, если смесь обедняется больше указанной, и давление выше указаного.

По загрузке форсунок
Отсечка, если загрузка выше указаной. Вы можете указать значения загрузки выше 100%

Температура двигателя

Органичение оборотов
ограничитель оборотов 50% от максимальных ниже указаной Т
Ограничения плавно снимаются при превышении температуры на 20 градусов.
Например задано значение 20 градусов. Ниже 20 - полное ограничение. От 20 до 40 ограничение плавно снижается. Выше 40 - нет ограничений.

Отключение наддува
отключается наддув ниже указаной Т

Ограничение мощности
Выше указаной Т:
- ограничивается давление наддува
- ограничиваются обороты
- прикрывается эл.дроссель

Ограничения полностью включаются при превышении температуры на 5 градусов.
Например задано значение 105 градусов. Ниже 105 - нет ограничений. От 105 до 110 ограничения плавно увеличиваются. Выше 110 - полное ограничение.

Масло

Ограничение мощности
- ограничивается давление наддува
- ограничиваются обороты
- прикрывается эл.дроссель
Ограничение плавно нарастает от нижнего порога до верхнего.

Откл. двигателя
Двигатель будет заглушен, если:
- подключен датчик давления масла. см. Входы
- обороты выше указаных
- датчик сигнализирует аварийное давление больше указаного времени


Прошивка

Техническая информация

Здесь находится техническая информация, которая прошита в постоянной памяти вашего ЭБУ (версия платы, конфигурация выходов, наличие опций и доп. модулей, и т.п.)

Защита калибровок

Эта функция включает защиту калибровок от чтения.

При включении защиты вы задаете пароль. После этого из блока читаются нулевые значения.

Для отключения защиты необходимо ввести пароль. Есть одна попытка. При вводе неправильного пароля все калибровки обнуляются, и защита отключается.


Настройка режимов ДАД+ДПДЗ
Данные режимы предназначен для атмосферных двигателей, и все что здесь сказано относится только к атмосферным двигателям.

Управление атмосферным двигателем только по ДАД имеет недостатки:

1. На низких оборотах давление в коллекторе достигает 100 кПа уже при 10-30% открытия дросселя. При дальшейшем нажатии педали никакого регулирования не происходит, поскольку давление в коллекторе уже не меняется. Для водителя это проявляется как отсутствие реакции на нажатие педали.

2. Обогащение смеси при давлениях близких к 100 кПа приводит к повышенному расходу топлива, потому что 100 кПа достигается уже при 10-30% дросселя. Получается, что большинство времени смесь обогащенная. Если же смесь не обогащать, оставив стехиометрию, то это воспринимается как “тупизна” - машина не хочет ускоряться при нажатии педали

Для устранения этих недостатков был создан режим ДАД+ДПДЗ, а затем и ДАД+ДПДЗ2. Суть их в том, что до 100 кПа нагрузка рассчитывается по ДАД, а при достижении 100 кПа нагрузка рассчитывается по ДПДЗ. Таким образом получается гораздо более гибкая настройка, которая устраняет обе проблемы, описанные выше.

Калибровка дросселя

Основной настройкой, напрямую влияющей на правильность работы алгоритма является открытие дросселя, при котором достигается 100 кПа . Эта таблица находится в калибровках дросселя. Ее значения указывают при каком положении дросселя в коллекторе достигается давление около 100 кПа.

Примеры настроек
AUDI AAR 5цил 2.3л. Особенность этого мотора - два дросселя разного размера, открывающихся по очереди, как на двухкамерном карбюраторе. Поэтому переход на ДПДЗ происходит при относительно больших положениях дросселя.

Ford 1.8л OHC. Один большой дроссель, в результате 100 кПа достигается очень быстро.

Настройка карт топлива и зажигания

Отличие ДАД+ДПДЗ2 от ДАД+ДПДЗ - в способе разбивки карты на зоны по ДАД и по дросселю. В примерах подана разбивка карт наполнения. Точно так же выглядят разбивка карт зажигания, смеси и фазы.

Режим ДАД+ДПДЗ
По вертикали - положение дросселя в условных единицах от 1 до 16 (от 0 до 100%).

Граница ДАД-ДПДЗ нелинейна, и зависит от точки переключения. Этот режим хорошо работает только в редких случаях.Обычно предпочтительнее использовать ДАД+ДПДЗ2

Пример настройки:

Режим ДАД+ДПДЗ2

Карта разделена на две части 50/50. Разбивка не зависит от точки переключения. Это намного удобнее. В левой колонке сначала значения от 20 до 100 в кПа. Затем от 10 до 16 - условные значения нагрузки.

Настройка смеси

Настраиваем в карте смеси 14.7 по всей зоне работы по ДАД. Обогащение делаем только при переходе в зону работы по ДПДЗ.